Bug #14351

Shortcut pages incompatible with mount point

Added by old_vibber about 17 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2004-10-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

When mounting a collection of pages I encounter an error if one of the mounted pages is a shortcut to another page.
The mounted page does does not show correct links or info from the setup field

Reproduce:
1. Make a collection of pages. One page should be a shortcut to another one of the pages

2. Mount the collection of pages with a mountpoint

3. Check in the browser by previewing the mount point page and browse the collection of pages to preview the page that is a shortcut. It does not display links correctly or take information from the setup field of the mountpoint

Note that this was only tested on a production site not a clean typo3 installation.
(issue imported from #M411)


Related issues

Related to TYPO3 Core - Bug #14827: Page mount points & manually added cross domain links are not workingClosed2005-06-17

Actions
Related to TYPO3 Core - Bug #29584: Shortcut to mountpoint results in illegal root treeRejected2011-09-09

Actions
Related to TYPO3 Core - Bug #17537: Shortcuts within mounted trees lose MP-ParameterClosed2007-08-16

Actions
#1

Updated by Rupert Germann over 16 years ago

I can't reproduce what you described (with TYPO3 3.8.0dev).
one thing I don't understand: what means " take information from the setup field of the mountpoint" which setup field ? the table "pages" has no setup field.

#2

Updated by ST about 16 years ago

Solving only a part of the problem:

Add to the Setup of either page A or page B (or both, i don´t remeber ;-)
config.linkVars=MP
This will add the needed MP-var to your url for browsing in remote trees:
Every Link will look like this: index.php?id=5&MP=34-89

Behavior: If you load a pagetree B from another part of your Website with all its subpages to page A...

In BE:
---page A (mount point)
|
|---page
|    |---page B (mounted page tree from here)
|    |       |---page C
|    |       |       |---page D

So, if you come over page A, your menu will look like this in FE:

|---page A
|       |---page C
|       |       |---page D

If you come directly over page B, you will see this in FE:

|---page B
|       |---page C
|       |       |---page D

Every pagetree may have its own setup and layout, so you can reuse a pagetree from two locations with two different setups (like symlinks in Linux).

The problem: If there´s a "shortcut" page in line, for example page C is a shortcut to page D, you will not stay in the setup (and layout) of page A, even if you come from that page. The shortcut is hard and changes the rootline to the mounted pagetree, so you will definetly get a real jump to page D with all the setup (and layout ) of the above pagetree (inherited from page B).

My question is: Why is a shortcut unable to take the MP-var further to its target page? A bug?

#3

Updated by Wolfgang Klinger over 15 years ago

Confirmed

#4

Updated by Wolfgang Klinger over 15 years ago

That's rather hard to solve as a shortcut is set to a specific page id. I can imagine a solution for the shortcut type "first subpage", everything else is not easily possible IMHO.

Any further ideas on this?

#5

Updated by Martin Holtz over 11 years ago

I had a special directory of shortcut-pages which i need to work with mountpoints. As typolink does the job well, i added doNotLinkIt = 1 and creat the link via typolink.

lib.directory = HMENU
lib.directory {
special = directory
special.value = 123
1 = TMENU
1 {
NO = 1
wrap = <ul>|</ul>
NO.allWrap = <li>|</li>

NO.doNotLinkIt = 1
NO.stdWrap.typolink.parameter.field = shortcut
}
}
#6

Updated by Susanne Moog about 10 years ago

  • Target version deleted (0)
  • TYPO3 Version changed from 3.7-dev to 4.5
  • Complexity set to hard
#7

Updated by Patrick Lobacher almost 10 years ago

Can confirm this:

Mounting to a page which is a shortcut to another page (even "first subpage") fails with an error message. If I remove the shortcut - it works.

As we had this "support feature" earlier in the Mantis Bugtracker I will introduce this here in Redmine again and so I will sponsor this issue with 100 EUR if some finds a solution to get MountPoints working with shortcut pages ("first subpage" is enough).

#8

Updated by Jigal van Hemert almost 9 years ago

  • Status changed from Needs Feedback to Accepted
#9

Updated by Alexander Opitz over 8 years ago

Does the problem is fixed by the patch of #29584 ?

#10

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

no feedback, so assuming "yes"

Also available in: Atom PDF