Bug #20873

Preview of hidden page translations is not possible

Added by Tobias Pinnekamp about 12 years ago. Updated 16 days ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-08-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the translation of a page is marked as hidden and the default language is not and you try to preview it, you'll get an error in the frontend that the "Page is not available in the requested language". With the default language of a page previewing is possible without restrictions.

The problem seems to be line 796 in class.tslib_fe.php

$res = $GLOBALS['TYPO3_DB']->exec_SELECTquery('hidden', 'pages', $idQ.' AND hidden!=0 AND deleted=0');

Here is checked if the default language of a page is hidden. If so the preview flags will be set. If not, preview mode is disabled, so that in further processing no page translation overlay will be found because the method t3lib_pageSelect::enableFields checks against "hidden=0".

The only way to show hidden page translations in the frontend is to use the admin panel and set the flag "Show hidden records". But this is a little bit inconsistent for a backend user if he just uses the magnifiying glass icons to show up pages.

(issue imported from #M11704)

#1

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

#3

Updated by Tim Jungebluth over 6 years ago

I got the same problem with TYPO3 6.2.x.

If I hide - or disable - a translation of a site in the backend, then there is no preview site. Instead an error is thrown.
The disabled default site with the default language is shown in the preview mode correctly with the red "PREVIEW!" label.

#4

Updated by Patrick Broens almost 4 years ago

Although a very old issue, it is still relevant for TYPO3 version 8LTS (8.7)

#5

Updated by Sven Burkert about 2 years ago

Yes, it is. In Version 8.7.27 this problem still exists.

#6

Updated by Reinhard Hiebl over 1 year ago

Using 9.5.13 and disabled translated page throws an error insead an preview page.
Still no solution?

#7

Updated by Georg Ringer over 1 year ago

Are you on same domains for the translation and the backend?

#8

Updated by Ronny Hauptvogel over 1 year ago

I run into trouble with TYPO3 10.4.2, too.

The page is disabled in the page tree and the default language could be viewed by an editor, but the translated one not.

Domain structure is like this:
  • editor is logged in via example.com/typo3
  • the hidden page "test" is viewable by example.com/test
  • but the hidden translation example.com/en/test is not viewable and "The page did not exist or was inaccessible. Reason: ID was not an accessible page" occurs
#9

Updated by ondro no-lastname-given about 1 year ago

  • TYPO3 Version changed from 4.2 to 9
  • PHP Version changed from 4.3 to 7.2

Can confirm same behaviour on typo3 9.5.15

#10

Updated by Stefan Neufeind about 1 year ago

  • Status changed from Closed to New
#11

Updated by Joachim Eckerlin 5 months ago

  • TYPO3 Version changed from 9 to 10
  • PHP Version changed from 7.2 to 8.0

The problem is still present in Version 10.4.16

#12

Updated by Marco H 3 months ago

Is this the longest living bug? :) Still an issue in 10.4.18

#13

Updated by Jochen Roth 18 days ago

Hey, could not reproduce this issue under latest master (v11.5). It seems to work now.

#14

Updated by Marco H 16 days ago

  • TYPO3 Version changed from 10 to 11
  • PHP Version changed from 8.0 to 7.4

Jochen Roth wrote in #note-13:

Hey, could not reproduce this issue under latest master (v11.5). It seems to work now.

Did some basic testing, these are the results:

TYPO3 10 (10.4.18 and 10.4.21):
page in default language enabled, page translation disabled -> page translation shown as preview in Frontend
page in default language disabled, page translation disabled -> page translation shown as preview in Frontend
page in default language disabled, page translation enabled -> page translation not accessible in Frontend *

TYPO3 11 (11.5.1):
page in default language enabled, page translation disabled -> page translation shown as preview in Frontend
page in default language disabled, page translation disabled -> page translation shown as preview in Frontend
page in default language disabled, page translation enabled -> page translation not accessible in Frontend *

  • Page Not Found
    The page did not exist or was inaccessible. Reason: ID was not an accessible page

Regarding my comment from before, I might've misread the previous reports and I had a bug that shows the same error, but was caused slightly differently. Maybe Joachim Eckerlin can recheck what caused the bug for him.

So, the combination of disabled page and enabled translation is an issue in current versions of 10 and 11.

Also available in: Atom PDF