Feature #20933

Enable working with SysFolders in CONTENT

Added by Sebastian Michaelsen over 10 years ago. Updated 4 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2009-08-26
Due date:
% Done:

100%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

When using the pages table in CONTENT, only pages with doktype below 200 will be queried, but it should be possible also to fetch SysFolders.

The patch adds a new TS property CONTENT.select.dontCheckDoktype to enable all pages no matter what doktype.
(issue imported from #M11797)

dontCheckDoktype.patch View (585 Bytes) Administrator Admin, 2009-08-26 23:47

checkDoktype.diff View (620 Bytes) Administrator Admin, 2009-11-30 10:43


Related issues

Related to TYPO3 Core - Bug #18079: slide of cObj CONTENT stops if sysfolder in rootline Resolved 2008-01-30

Associated revisions

Revision 6d2db4f7 (diff)
Added by Benni Mack 4 days ago

[BUGFIX] Enable rootline / content access to sysfolders

Only disallow DOCTYPE_RECYCLER in rootline and cObj->checkPid(),
instead of disallowing DOCTYPE_SYSFOLDER.

This makes it possible to fetch content from sysfolder pages.

At the same time, a hard check on accessing sys folders is added
to TSFE.

Resolves: #18079
Resolves: #20933
Releases: master
Change-Id: Ieb54d139bc1e7fc489c35f70510800be8ff14fb9
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64038
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Tested-by: Oliver Bartsch <>
Tested-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Sebastian Michaelsen over 10 years ago

Attached patch introduces property checkDoktype to avoid the negative naming.

#2 Updated by Alexander Opitz almost 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

#4 Updated by Sebastian Michaelsen about 5 years ago

  • Status changed from Closed to New

This issue is still present. I will fix it. (Hint: ContentObjectRenderer:8026 is probably where you want to take a look)

#5 Updated by Benni Mack almost 5 years ago

  • Status changed from New to Accepted

Sebastian, could you provide a patch in gerrit? thx

#6 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41671

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41671

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41671

#9 Updated by Mathias Schreiber about 4 years ago

  • Status changed from Under Review to New

#10 Updated by Susanne Moog over 2 years ago

  • Related to Bug #18079: slide of cObj CONTENT stops if sysfolder in rootline added

#11 Updated by Susanne Moog over 2 years ago

  • Category set to Frontend

#12 Updated by Sybille Peters about 2 years ago

Thank you for your report.

Even though it has been some time, would you consider checking if your patch idea is still up to date and upload it to our Gerrit review server?

Someone could do this for you, but I am thinking you might like the opportunity to contribute to TYPO3 yourself.

You can find a description of the TYPO3 contribution workflow here: https://docs.typo3.org/typo3cms/ContributionWorkflowGuide/

Hint: If you get stuck anywhere, ask on Slack in the #typo3-cms-coredev channel. You can register in the TYPO3 slack workspace here: https://forger.typo3.com/slack

Thank you in advance!

#13 Updated by Clemens Riccabona about 1 year ago

Would be great to have a solution for this ...

#14 Updated by Benni Mack about 1 year ago

Hey all,

following up on the twitter discussion here....

https://twitter.com/thomas_hempel/status/1103655082929909760

Can you explain what your use case is?

Fetching stuff from sys folders in general is no issue, and should work already.

When do you actually want to show a sys folder in the frontend? Adding an option is doable, but adding an option for the sake of it and a special use-case seems weird to me.

For a more generic approach, I tried to actually "not care" about any doktypes except 255 (recycler), thus including all the other magic fields, so this could e.g. work for mount points, which would make sense IMHO. But this would lead that people can actually link to a storage folder (because PageRepository is used for linking as well and validating valid pages in FE).

So, if we get more input on what (all of you) try to achieve, we can find a better solution with a cleaner architecture in general, and avoid (even more) magic.

#15 Updated by Sebastian Michaelsen 6 months ago

Usually when I try to read a sysfolder in TS, it's not to actually present any of its data in the frontend but to use its uid in other TypoScript functions such as where.pidInlist.

I have an Extension on Github that cured my itch in several projects: https://github.com/smichaelsen/typo3-folder-cobj

#16 Updated by Gerrit Code Review 7 days ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64038

#17 Updated by Gerrit Code Review 6 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64038

#18 Updated by Gerrit Code Review 5 days ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64038

#19 Updated by Benni Mack 4 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF