Feature #26139

Story #82206: list module enhancements/bugfixes

un-/hide multiple records with one click

Added by Bernd Wilke over 9 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Could have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-04-20
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

using the clipboard 1 to 3 (other than normal) you can do some edits/ changes to multiple records at once:

  • copy/move (with the actual clipboard,
  • edit,
  • delete

but you can't hide/unhide multiple records at once.

clicking fast multiple lightbulbs (Extended view) an rebuild/reload of the BE will limit you to just a few records which change status (by racing requests?)

would it be possible to un-/hide multiple (selected) records with one click?
would it be possible to have further action to multiple (selected) records at once?


Related issues

Related to TYPO3 Core - Feature #65069: Easy multiselect for checkboxes (for list view)NewBenni Mack2015-02-14

Actions
Related to TYPO3 Core - Epic #90676: Clipboard related bugs and featuresAccepted2020-03-07

Actions
Related to TYPO3 Core - Feature #40690: List-view: Mass-setting a valueNew2012-09-07

Actions
#1

Updated by Georg Ringer over 9 years ago

  • Status changed from New to Closed

this is already possible!

  1. click on the '+' next to the table header and select the field you want to change (e.g. hide) and click button "set fields".
  2. enable clipboard 1-3 and tranfer the elements you want to edit
  3. press edit icon next to the new header (called "edit the '<fieldname>' of the listed records

tested with 4-6 but IMO should work since a long time that way

#2

Updated by Bernd Wilke over 5 years ago

  • Status changed from Closed to New
  • Target version set to 7.4 (Backend)

maybe this could be realized for 7.x to have a better UI

#3

Updated by Susanne Moog over 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Benni Mack about 5 years ago

  • Target version changed from 7.5 to 8 LTS
#5

Updated by Georg Ringer about 5 years ago

  • Status changed from New to Needs Feedback

with 7 LTS hide/unhide is now using ajax, would that be enough for you in the meantime? for next versions like 8-9 there are thoughts to add features which are support "power-users" even more, like having better mass editing.

#6

Updated by Bernd Wilke almost 5 years ago

so it is easier to en-/dis-able multiple records in a short. there is a difference to the intended behaviour of having multiple records switched at the same time.
especially if you need this small timeframe and having a not so simple selection. and selecting all records (with the option to unselect just a small number) would be spare a lot of clicks.

maybe in 8

#7

Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to New
#8

Updated by Riccardo De Contardi almost 4 years ago

  • Target version changed from 8 LTS to 9.0
#9

Updated by Benni Mack over 3 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (9.0)

Hey Bernd,

could you please let us know how we should tackle this one with touch devices in mind?

#10

Updated by Bernd Wilke over 3 years ago

I assume we still have an option to select multiple records for further action. On touch devices selections often are done with a mini-slider instead of simple checkboxes.
the other aspect is the question how to select the action to execute with all selected records. till now there were individual buttons above the checkbox column. with a lot of actions there might not be enough space for all that buttons. so you always can do a 'drop-down' (on touch devices sometimes as a popup) selection (with an execute button)

#12

Updated by Mona Muzaffar over 3 years ago

  • Related to Feature #65069: Easy multiselect for checkboxes (for list view) added
#13

Updated by Alexander Opitz about 3 years ago

  • Status changed from Needs Feedback to New
#14

Updated by Riccardo De Contardi almost 3 years ago

  • Parent task set to #82206
#15

Updated by Christian Eßl 9 months ago

  • Related to Epic #90676: Clipboard related bugs and features added
#16

Updated by Riccardo De Contardi 8 months ago

Also available in: Atom PDF