Bug #32756

Massive Memory Leak in 4.5.8+ / 4.6

Added by Ronny Vorpahl about 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2011-12-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

This Bug is caused by the fix for #15984

... due to patched tslib_fe::checkPageGroupAccess used by tslib_cObj::getTreeList

When a treelist is built by tslib_cObj::getTreeList, the access rights are checked using tslib_fe::checkPageGroupAccess.
Due to the Patch #15984 the rootline is now loaded for EVERY PAGE IN THIS TREELIST, just to check the rights of the parent pages.
It seems the PHP Garbage collection fails in this case causing a memory limit exception.
The implementation of t3lib_pageSelect::getRootLine itself seems to be alright.

An example (limited test case):
Creating a full treelist of 537 pages in 4 levels (1+14+138+384 pages) resulted in over 10330 calls of t3lib_DB::execSelectQuery and 10330 t3lib_DB::sql_fetch_assoc just for t3lib_pageSelect::getRootLine. The memory limit had to be raised to 1GB or the call failed with an exception.

This case was experienced in multiple PHP 5.3 environments.

xhprof PHP-Profiler including compared callgraphs are available.
Two solution(s) are also on their way, but are still work in progress.

Please contact us for further details ...


Files

patch_32756.diff (2.25 KB) patch_32756.diff Ronny Vorpahl, 2011-12-22 15:20
xhprof_PHP-Profiler_getTreeList_4.5.7.htm (34.7 KB) xhprof_PHP-Profiler_getTreeList_4.5.7.htm Ronny Vorpahl, 2011-12-22 15:20
xhprof_PHP-Profiler_getTreeList_4.5.9.htm (40.5 KB) xhprof_PHP-Profiler_getTreeList_4.5.9.htm Ronny Vorpahl, 2011-12-22 15:20

Related issues

Related to TYPO3 Core - Bug #34800: Page tree not respondingClosedMathias Schreiber2012-03-13

Actions
Follows TYPO3 Core - Bug #15984: menu.showAccessRestrictedPages doesn't replace link for "include subpages"Accepted2006-04-05

Actions

Also available in: Atom PDF