Bug #34800

Page tree not responding

Added by Traude Gratzer over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Category:
Pagetree
Target version:
-
Start date:
2012-03-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It seems that the page tree is freezing sometimes. You are not able to expand or minimize anything anymore, neither are the pages loading itself. A simple page refresh is not fixing the problem apparently.

This problem mostly occurs when we got a high amount of active backend users in the system, when a lot of new pages are generated.

Mostly we got that issue while using the Internet Explorer (Version 7-9), we got one case with Firefox as well so far.

IE itself throws a JS error in that case: Exception for ext-all.js Message: Object does not support this property or method. Line 7. Character: 293703 Code:0 URI:http://[myUrl]/typo3temp/compressor/ext-all-47d01fd711d179f02a4da5eeaafb352b.js "

Sadly we analyzed the script without any further results.

We got this behavior with the following typo3 versions: * 4.5.2 * 4.6.2 * 4.6.5

Further information: * php 5.3 * Apache 2 * MySQL 5.x

Does anybody else got the same problem, or knows a possible reason/solution?

Best regards,
meggie


Related issues

Related to TYPO3 Core - Bug #32756: Massive Memory Leak in 4.5.8+ / 4.6Closed2011-12-21

Actions
Related to TYPO3 Core - Bug #45800: IE9, pagetree: Can't collapse subtreesClosed2013-02-24

Actions
#1

Updated by Oliver Hader over 9 years ago

  • Status changed from New to Needs Feedback

Could not reproduce this behaviour - however, maybe it's related to the size of your system and the amount of pages...
Can you please enable the debug mode in the Install Tool (TYPO3_CONF_VARS[BE][debug]) - this leads to the situation, that JavaScript file are not compressed anymore and makes it easier to look-up what happens on the JavaScript part.

So, after setting the "debug" flag, please report again the JavaScript error and any other possible timeouts/failures of AJAX requests. Thanks.

#2

Updated by Michael Schreiner over 9 years ago

I can see the same symptoms on a system running 4.5.15 and 4.5.17.

Once the JS error occurs, the elements in the page tree are no more expandable or collapsible. A click on the refresh button on top of the tree view results in the tree showing the root element only. A reload of the page leads to the same error. Collapsing the tree by clearing the cache or using a non affected browser helps. The JS error then shows up again when expanding certain parts of the page tree, but this behaviour is not 100% reproducible.

In my tests only the IE 8 and the IE 9.0.8112.16421 in IE 7 or IE 8 mode were affected, IE 9 in normal mode, Firefox 13.0.1 and Chrome 20.0.1132.47 did not have any problems.

There is another problem which seems to abet the JS error: using IE 8 (or IE 9 in IE 7 or 8 mode) a click on the edit link icon for image links in content elements forces a logout. After logging in again the chances for the JS error appearing immediately seem to be higher.

The debug mode showed the error to be in line 22041 of file typo3_src-4.5.17/typo3/contrib/extjs/ext-all-debug.js

Ext.dd.Registry = function(){
    var elements = {};
    var handles = {};
    var autoIdSeed = 0;

    var getId = function(el, autogen){
        if(typeof el == "string"){
            return el;
        }
        var id = el.id;
        if(!id && autogen !== false){
            id = "extdd-" + (++autoIdSeed);
->          el.id = id;

As the error shows up very quickly, and the server is connected via LAN a timeout is unlikely.
Another user (not connected via LAN) reported the error message: "'TYPO3.Flashmessage' is null or not an object" in backend.php line 93, char 6 when having trouble with the page tree in his IE 8. All users on this system are admins, so this is probably not the same issue as in Bug #25433.

In a short test with an older version of IE 8 (8.0.6001.18702) neither the problem with the page tree, nor the logout when clicking the link icon for images occurred.

I have replaced the typo3_src-4.5.17/typo3/contrib/extjs directory with version 3.4.0 of ExtJs and cleared the /typo3temp/compress directory, but this had no effect on the error.

#3

Updated by Florian Busch (floxx) over 9 years ago

Same here. Error occurs in IE Versions 7-9. TYPO3 4.6.10

#4

Updated by Andreas Kiessling about 9 years ago

A client just reported the same issue in 4.5.19. I could only reproduce this once in IE8. The debugger pointed to the exact same line in ext-all

Update: reproducable in IE9 on Win7

#5

Updated by Andreas Kiessling about 9 years ago

I think that some nodes/dom elements are not properly initialized in IE when the tree is reloaded.

I've added a console.log(el); right above "el.id = id" and this usually puts out

LOG: [object HTMLDivElement] 

but if an error occurs, a Text object this is logged:
LOG: [object Text]

I have no idea, which element causes this, but with "Expand Branch" from the "Branch Actions", i could trigger this error sometimes, after i reloaded it with the button in the upper right corner.

With the initially loaded tree, the error did not happen.

#6

Updated by Roger Bunyan about 9 years ago

A client of mine has the same issue in IE on ver 4.5.19,

#7

Updated by Philipp Idler about 9 years ago

I can confirm this issue.

TYPO3 4.5.19
IE8 and also
IE9 - compatibility mode IE8

#8

Updated by Kai about 9 years ago

I can confirm this issue.

Typo3 4.7.4
IE8

IE8 Error Messages:
-----
Details zum Fehler auf der Webseite

Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)
Zeitstempel: Wed, 24 Oct 2012 14:14:49 UTC

Meldung: Das Objekt unterst├╝tzt diese Eigenschaft oder Methode nicht.
Zeile: 7
Zeichen: 293703
Code: 0
URI: typo3temp/compressor/ext-all-1e26a50ae24288a3a34b8134815c38b9.js
---

#9

Updated by Nils Blattner almost 9 years ago

I can confirm this issue aswell:
PHP 5.3.16 on an IIS7.5
TYPO3 4.5.16

The customer is using IE8, where the effect occurs frequently. We can only reproduce it every now and then.
When I activate extjs debug mode, IE8 cannot cope with the CSS-files anymore.

As soon as the Bug hits, the backend is unusable for the users.

IE8 Error:
-----------
Details zum Fehler auf der Webseite

Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Zeitstempel: Fri, 14 Dec 2012 10:10:55 UTC

Meldung: Das Objekt unterst├╝tzt diese Eigenschaft oder Methode nicht.
Zeile: 7
Zeichen: 292305
Code: 0
URI: http://intranet.ft.feintool.local/typo3temp/compressor/ext-all-3079bfddc9510f2998808fdb049d1bef.js


#10

Updated by Nils Blattner almost 9 years ago

Does anyone have a working solution to this problem?

#11

Updated by Jonas Felix over 8 years ago

We currently run tests with EXTJS 3.6 which maybe fixes the problem...

We'll keep you up to date.

#12

Updated by Daniel Ostmann over 8 years ago

I can confirm this issue for version 4.7.7, in IE 8 and 9.

#13

Updated by Michael Stucki over 8 years ago

Had the same problem using an old IE7. In our case, we were lucky enough that it only happened in an Intranet website. The solution therefore was to install Google Chrome Frame on all PCs that need backend access. This will solve the problem and will also give a way better experience for the users, because the whole backend is a lot faster than before...

When using Chrome Frame, make sure to enforce it not only for the backend (which is done by default) but also for the frontend. The most easy solution for this is to install mod_headers in Apache and put the following into .htaccess at the document root:

Header set X-UA-Compatible "IE=edge,chrome=1" 

Source: http://www.chromium.org/developers/how-tos/chrome-frame-getting-started

Important: To make this work, we also need to disable a security check due to different session IDs for multiple Chrome frames:

$TYPO3_CONF_VARS['BE']['lockHashKeyWords'] = '';
$TYPO3_CONF_VARS['FE']['lockHashKeyWords'] = '';

See #22336 for details...

#14

Updated by Nils Blattner over 8 years ago

We tried to circumvent this issue by using the latest EXTJS 3.4 instead of the standard 3.3.1 in a TYPO3 4.5.16.
However the issue was not solved by this.

Installing Chrome Frame is not an option for any of our customers that experience this issue!

Is anyone still actively investigating this bug?

#15

Updated by Nils Blattner over 8 years ago

We are willing to sponsor this issue.

If you are interested and able to provide a solution patch, please contact me about the bounty.

#16

Updated by Alexander Opitz about 8 years ago

  • Is Regression set to No

Does someone have this issue with TYPO3 CMS 6.1.x?

#17

Updated by David Bruchmann almost 8 years ago

With Version 6.1.3 I've the following behavior (already long time) [this is for the tree in the window for choosing pictures for content-elements]:

When a subtree is expanded the links of the before hidden subfolders never work (at least in chrome).
Reloading the tree brings the links and the folders are click-able.


Now I've the problem (also Version 6.1.3) that the tree in the main-window is not loaded. I just had to switch-back the PHP-Version to 5.4. due to another bug (http://forge.typo3.org/issues/53682) but deleting the cache never makes the missing tree appear.

The Error-message in the console is:
Uncaught TypeError: Cannot read property 'type' of null ext-all-aee2a79b7f5329f61f2464e119c9e950.js:7
The corresponding part of the minified line:
createEvent:function(a,b){return new Ext.Direct.eventTypes[a.type](Ext.apply(a,b))}

Update: After playing a bit with the general PHP-Configuration and loaded PHP-Extensions this second error with ExtJS disappeared.

#18

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
#19

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

is this still happening on 6.2 or 7?

We run installs with more than 50k pages and never had that issue.

#20

Updated by Tizian Schmidlin over 6 years ago

Looks fixed from here too.

#21

Updated by Mathias Schreiber over 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF