Bug #37988

COA_INT in Fluid-Templates

Added by Alexander Wende over 7 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-06-13
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

I think this is a related bug to http://forge.typo3.org/issues/36820
Passing a coa_int object to a fluidtemplate cause
an <!--INT_SCRIPT output like wrapping a coa_int in another coa_int.
atm the fluid template has no partials...

Can anybody confirm?

  10 = FLUIDTEMPLATE
  10 {
      file = {$filepaths.templatePath}{$filepaths.templatefile}
      partialRootPath = {$filepaths.partialPath}    
      layoutRootPath = {$filepaths.layoutPath}   
      variables{
         username = COA_INT
         username.10 = TEXT
         username.10.value = some username
      }
   }

Typo3 4.6.9


Related issues

Related to TYPO3 Core - Bug #44825: Pagerenderer / page.headerData + USER_INT is not working Closed 2013-01-26

History

#1 Updated by Christian Kuhn almost 7 years ago

  • Status changed from New to Needs Feedback

@Alexander: We've have a nifty patch in this area for TYPO3 CMS 6.0. Is this still reproducible for you with this core version?

#2 Updated by Alexander Opitz over 6 years ago

No feedback for over 90 days.

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

#4 Updated by Christian Eßl over 6 years ago

I can confirm this in TYPO3 6.1.3 when using the cObject viewhelper.

lib.test = COA_INT
lib.test {
10 = TEXT
10.value = test
}

{f:cObject(typoscriptObjectPath: 'lib.test')}

leads to output like this:

<!--INT_SCRIPT.3c13b85fb8cdae5e1456aa38ef777282-->

#5 Updated by Sander Leeuwesteijn about 6 years ago

This is also happening in 6.1.5!

#6 Updated by Manuel Thaler almost 6 years ago

Sander Leeuwesteijn wrote:

This is also happening in 6.1.5!

Still seems to be a problem. Any idea how to solve it?
This here didn't solve it either:
http://forge.typo3.org/issues/37988

Maybe you have a look at this:
http://www.typo3.net/forum/thematik/zeige/thema/90982/?show=1

#7 Updated by Xavier Perseguers over 4 years ago

  • Status changed from Closed to Accepted
  • Target version set to 6.2.14
  • Is Regression set to No
  • Sprint Focus set to Stabilization Sprint

Can reproduce the problem. Should get fixed finally :)

#8 Updated by Helmut Hummel over 4 years ago

  • Status changed from Accepted to Needs Feedback

Christian Eßl wrote:

I can confirm this in TYPO3 6.1.3 when using the cObject viewhelper.

lib.test = COA_INT
lib.test {
10 = TEXT
10.value = test
}

{f:cObject(typoscriptObjectPath: 'lib.test')}

I cannot confirm this. Using the cObject view helper works like expected

#9 Updated by Helmut Hummel over 4 years ago

It is important to not htmlencode the output of a COA_INT or USER_INT

The following code could be used in case the COA_INT is used as Fluid variable in TS

<f:format.raw>{username}</f:format.raw>

With that, everything works like expected.

#10 Updated by Xavier Perseguers over 4 years ago

  • Status changed from Needs Feedback to Resolved
  • % Done changed from 0 to 100

Thanks for the hint.

#11 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

#12 Updated by Vasyl Mosiychuk 3 months ago

  • TYPO3 Version changed from 4.6 to 9
  • PHP Version changed from 5.3 to 5.5

This issue not resolved for me...

in TS


lib.currentUidUserInt = COA_INT
lib.currentUidUserInt {
    10 = TEXT
    10.data = TSFE:fe_user|user|uid
}

In FLUID


{f:cObject(typoscriptObjectPath:'lib.currentUidUserInt') -> v:variable.set(name:'foo')}

here I get `UID` and it is works


{foo -> f:format.raw()}

But here I get problem


<f:if condition="{0:'{newsFeUser.0.uid}'} == {0:'{foo -> f:format.raw()}'}">

I get...


<!--INT_SCRIPT.747d1dced8da2c172a57e825026c429b-->

Also available in: Atom PDF