Bug #39967

mod.SHARED.colPos_list is not taken into account any more

Added by Helmut Hummel over 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Miscellaneous
Target version:
Start date:
2012-08-19
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Since the merge of the https://review.typo3.org/13510
mod.SHARED.colPos_list is not taken into account any more as a hardcoded backend layout is used with all columns.


Related issues

Related to TYPO3 Core - Task #39603: Move default columns to a backend_layout configuration Closed 2012-08-08
Related to TYPO3 Core - Bug #43511: Page TSconfig option mod.SHARED.colPos_list does not work anymore Closed 2012-12-02
Related to TYPO3 Core - Bug #53898: Unused code in PageLayoutView (~100 lines) Closed 2013-11-23

Associated revisions

Revision 241f4d0e (diff)
Added by Jigal van Hemert about 5 years ago

[BUGFIX] colPos_list sets access to edit areas

The property mod.SHARED.colPos_list used to determine which columns
were visible in the Page module. With backend layouts it will only
determine which edit areas in the backend layout are accessible for
editing.

Resolves: #39967
Releases: 6.3, 6.2
Change-Id: Iba65ce84adf025802d1b0ebda00dff4d6299a06a
Reviewed-on: http://review.typo3.org/31783
Reviewed-by: Wouter Wolters <>
Reviewed-by: Marcin SÄ…gol <>
Reviewed-by: Jo Hasenau <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

Revision cb3dc5e4 (diff)
Added by Jigal van Hemert about 5 years ago

[BUGFIX] colPos_list sets access to edit areas

The property mod.SHARED.colPos_list used to determine which columns
were visible in the Page module. With backend layouts it will only
determine which edit areas in the backend layout are accessible for
editing.

Resolves: #39967
Releases: 6.3, 6.2
Change-Id: Iba65ce84adf025802d1b0ebda00dff4d6299a06a
Reviewed-on: http://review.typo3.org/32615
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

Revision 20de0fc4 (diff)
Added by Helmut Hummel about 5 years ago

[BUGFIX] Followup to mod.SHARED.colPos_list fix

The internal property activeColPosList is intermediately
set to an array and not converted to a comma separated list
any more, which breaks related code.

Resolves: #39967
Releases: 6.2, 6.3
Change-Id: I6f2e4710174ad5277f9de47c2d7b2cbb7a5ebb80
Reviewed-on: http://review.typo3.org/32697
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Nicole Cordes <>
Reviewed-by: Jo Hasenau <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

Revision 6a389870 (diff)
Added by Jigal van Hemert about 5 years ago

[BUGFIX] Followup 2 to mod.SHARED.colPos_list fix

Deal with empty mod.SHARED and fill activeColPosList with colPosList
in case the TSconfig setting is empty.

Resolves: #39967
Releases: 6.2, 6.3
Change-Id: I5e2e4420de8f1d603e13a03758f97803e545d9a3
Reviewed-on: http://review.typo3.org/32712
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision b60a40cb (diff)
Added by Helmut Hummel about 5 years ago

[BUGFIX] Followup to mod.SHARED.colPos_list fix

The internal property activeColPosList is intermediately
set to an array and not converted to a comma separated list
any more, which breaks related code.

Resolves: #39967
Releases: 6.2, 6.3
Change-Id: I6f2e4710174ad5277f9de47c2d7b2cbb7a5ebb80
Reviewed-on: http://review.typo3.org/32742
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 6d169dd5 (diff)
Added by Jigal van Hemert about 5 years ago

[BUGFIX] Followup 2 to mod.SHARED.colPos_list fix

Deal with empty mod.SHARED and fill activeColPosList with colPosList
in case the TSconfig setting is empty.

Resolves: #39967
Releases: 6.2, 6.3
Change-Id: I5e2e4420de8f1d603e13a03758f97803e545d9a3
Reviewed-on: http://review.typo3.org/32743
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Jigal van Hemert over 7 years ago

True, the setting is not taken in to account. This setting has actually been replaced by the concept of the backend layouts. If you need less columns you simply create a backend layout for that.
I'd like to drop this setting completely. There are a few solutions to help integrators during the upgrade:
  1. make an upgrade wizard which tries to find these settings and creates backend layouts; this is rather complicated as the setting might apply to a subtree of the site
  2. make an upgrade wizard which tries to detect the setting and explains how to solve it manually
  3. only document it

#2 Updated by Michael Stucki over 7 years ago

  • Status changed from New to Accepted
  • Complexity set to easy

I agree that an upgrade wizard could help to replace the old setting entirely. Anyone up for taking over this change?

#3 Updated by Oliver Hader about 7 years ago

Modified for Introduction Package with a new backend layout, see https://review.typo3.org/#/c/16793/

#4 Updated by Chris topher over 6 years ago

With #47071 we have updated the documentation of mod.SHARED.colPos_list so that the documentation says mod.SHARED.colPos_list has been removed.

The only thing that still needs to be done here is:

Remove mod.SHARED.colPos_list from the code completely.

#5 Updated by Jo Hasenau almost 6 years ago

Well - as usual - it is not that easy, since colPos_list and backend layouts are completely different things, with completely different tasks.

While backend layouts provide the structure as such, that will be available for a certain site, colPos_list is meant to restrict the access to these columns i.e. based on certain conditions.

AFAIK this has been working even together with backend layouts in TYPO3 4.x so removing it silently with 6.0 instead of fixing the bug will now result in additional problems for people who are upgrading from 4.5 LTS to 6.2 LTS.

IMHO we must revert the removal at least for 6.2, but actually this should be fixed in earlier versions as well.

#6 Updated by Helmut Hummel almost 6 years ago

  • Target version changed from 6.0.0 to 6.2.0
  • TYPO3 Version changed from 6.0 to 6.2
  • Is Regression set to No

I agree that we should provide a compatibility layer for that at least for 6.2

#7 Updated by Jo Hasenau almost 6 years ago

There is no need for a compatibility layer, since this has been a working feature, that was broken with the patch you mentioned in the description.
Removing it without deprecation is against our CGL, so it currently could not be removed before TYPO3 6.4 or 7.0

Actually it should not be removed, since it is used for another purpose than just a "poor man's backend layout".

#8 Updated by Patrick Broens almost 6 years ago

Agree with Joey,

The mentioned patch should be reverted and the issue should be fixed for all versions.

When having a backend layout, you sometimes want to prevent access to a certain column for some users/user groups. At one of my clients (a university) we are using the setting mod.SHARED.colPos_list together with backend layouts, and it works.

As mentioned by Jo colPos_list and backend layouts are completely different things. The first is for access, the second for structure.

#9 Updated by Peter Niederlag almost 6 years ago

+1 for reverting, backend layouts does in no way replace the functionality of mod.SHARED.colPos_list

#10 Updated by Helmut Hummel almost 6 years ago

Patrick Broens wrote:

As mentioned by Jo colPos_list and backend layouts are completely different things. The first is for access, the second for structure.

Not really true. The order of colPos_list also mattered and was used to identify the order of columns.

#11 Updated by Helmut Hummel almost 6 years ago

Peter Niederlag wrote:

+1 for reverting

reverting what? the layout change?

The question is: How to we deal with the situation. I see following possibilities:

  1. Restore mod.SHARED.colPos_list only when no backend layouts are present
  2. Restore mod.SHARED.colPos_list, but only ignore the order when backend layouts are present (using the info to hide containers with not matching ids)
  3. Add a new option that adds the possibility to remove containers by colpos from backend layouts
  4. Provide an Upgradewizard (or separate script) adding backend layouts if colPos_list is present (traversing the tree)

#12 Updated by Peter Niederlag almost 6 years ago

Prio I

  1. (Re-)Introduce mod.SHARED.colPos_list or introduce a new setting (I don't care to much on the name)
  2. Only purpose of the setting is to influence wether certain columns in dropdown-selections and the page-module are to be shown
  3. The order of the columns should not be within the scope of this setting (I am fine if it is for core)

Nice to have

  1. It might be nice to have both whitelisting as well as blacklisting options (something like colPos_showOnly and colPos_hide)
  2. It might be nice to have influence on the way columns are hidden (something like colPos_hiddenLayout = hidden|readonly)

#13 Updated by Ernesto Baschny over 5 years ago

  • Category set to Miscellaneous
  • Target version changed from 6.2.0 to next-patchlevel

This is indeed a feature upgraders from 4.x are expecting which was removed in 6.0. As we don't have time until 6.2.0 now (to be released in two days), I would opt on an "easy working solution" that we can include as a very special case after 6.2.0 (in 6.2.1 for example).

It should allow admins to do what the old setting did in regards of "hiding" undesired columns. The "order" is not the scope here, this is already handled by the backend layouts.

I would not put energy in Upgrade Wizards, as this can be documented and those who need it can think about how to use the new possibilities while upgrading.

Any candidate to work on a solution for this?

#14 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#15 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#16 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#17 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#18 Updated by Gerrit Code Review over 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#19 Updated by Gerrit Code Review over 5 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31783

#20 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32615

#21 Updated by Jigal van Hemert about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#22 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32697

#23 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32697

#24 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32697

#25 Updated by Gerrit Code Review about 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32697

#26 Updated by Helmut Hummel about 5 years ago

  • Status changed from Under Review to Resolved

#27 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32712

#28 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32712

#29 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32742

#30 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32743

#31 Updated by Jigal van Hemert about 5 years ago

  • Status changed from Under Review to Resolved

#32 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF