Bug #41413

link title got urlencoded in link-wizard

Added by Tobias Liebig almost 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2012-09-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

When opening the link-wizard form a link field, the title got urlencoded.

  • Create a new Content-Element, e.g. "Text only"
  • find a "Link" field and enter:
    • 1 _top - "foo bar"
    • (Title is wrapped by "" and contains a space)
  • open the link-wizard by clicking the "chain with pencil"-icon on the right
  • see the title got "urlencoded" and transformed to "foo%20bar"

See attached screenshot

Occurred in 4.5 and later versions.


Files

06-Schnappschuss.png (94.1 KB) 06-Schnappschuss.png Tobias Liebig, 2012-09-27 11:13
linkproblem.jpg (29.7 KB) linkproblem.jpg Mario Hirschfeld, 2012-10-11 18:18

Related issues

Related to TYPO3 Core - Bug #50929: Don't call rawurlencode() twice on curUrlClosedGeorg Ringer2013-08-08

Actions
Related to TYPO3 Core - Bug #51943: Quotes in RTE link title break HTML outputClosed2013-09-12

Actions
Related to TYPO3 Core - Bug #56289: Fix for URL-encoded title in link wizard introduced JS error ClosedMarkus Klein2014-02-25

Actions
Related to TYPO3 Core - Bug #61943: Fix JavaScript error that prevents links to anchor tags in RTEClosed2014-09-29

Actions
Related to TYPO3 Core - Bug #59199: Element Browser: GET-Data is not unencoded in fieldsClosed2014-05-29

Actions
Is duplicate of TYPO3 Core - Bug #31151: Link browser urlencodes existing title textsClosedAlexander Opitz2011-10-20

Actions
Has duplicate TYPO3 Core - Bug #39284: link wizard url encoding bug on updateClosed2012-07-26

Actions
Precedes TYPO3 Core - Bug #55759: Using double quotes in title of links breaks everythingClosedMarkus Klein2014-02-07

Actions
#1

Updated by Stefan Galinski almost 10 years ago

  • Status changed from New to Accepted
#2

Updated by Mario Hirschfeld over 9 years ago

Same here but with the link url:
f.e.: fileadmin%2Fuser_upload%2F

The link changed to urlencode after changing title or targetwindow with linkwizard.

#3

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/20034

#4

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/20034

#5

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23740

#6

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23740

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23740

#8

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23740

#9

Updated by Chris topher almost 9 years ago

  • Subject changed from link title got urlencoded n link-wizard to link title got urlencoded in link-wizard
  • Is Regression set to No
#10

Updated by Ernesto Baschny almost 9 years ago

Maybe this problem #51943 could be tackled at the same time - as it is related.

#11

Updated by Markus Klein over 8 years ago

  • Priority changed from Should have to Must have
#12

Updated by Markus Klein over 8 years ago

  • Target version set to next-patchlevel
  • Complexity set to medium

The "additional parameters" field is affected as well!

Affected versions are 4.5 to 6.2

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23740

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23740

#15

Updated by Gerrit Code Review over 8 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23740

#16

Updated by Gerrit Code Review over 8 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23740

#17

Updated by Gerrit Code Review over 8 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23740

#18

Updated by Helmut Hummel over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#19

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27853

#20

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27853

#21

Updated by Tobias Wollender over 8 years ago

With this Patch applied on 6.2 master, the linkbrowser for input fields (e. g. header_link) doesn't work correctly anymore. The tab "Page" gets displayed, but a click on any other tab results in a white page in the linkbrowser. The linkbrowser in the RTE works fine.

#22

Updated by Markus Klein over 8 years ago

There have been two further patches after this one. please try them together.

#56289, #56290

#23

Updated by Tobias Wollender over 8 years ago

I'm already on latest master, but the problem is as described in comment #21. I cleared all caches, but nothing changes. And unfortunately there is no output in the error_log I can post here.

#24

Updated by Markus Klein over 8 years ago

Ok thx. Will recheck.

#25

Updated by Thomas Sperling over 8 years ago

Same Problem: I think the error is in function jumpToUrl. The URL looks like this: typo3/browse_links.php?PM=0_0_0_browsePages&act=&mode=wizard%27&P[itemName]=data%5Btt_cont ...
Attention to wizard%27 there is one ' (=%27) to much, also at the end of the URL.

#26

Updated by Markus Klein over 8 years ago

Got it. Fixed in https://review.typo3.org/27924
Please test and vote. Thank you.

#27

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27853

#28

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27925

#29

Updated by Helmut Hummel over 8 years ago

  • Status changed from Under Review to Resolved
#30

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF