Bug #45800

IE9, pagetree: Can't collapse subtrees

Added by Stefan Neufeind almost 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Here the tree is fully expanded (and showing correctly). But I'm unable to collapse subtrees in IE.


Related issues

Related to TYPO3 Core - Bug #30202: IE9, pagetree missing icon.Closed2011-09-22

Actions
Related to TYPO3 Core - Bug #34800: Page tree not respondingClosedMathias Schreiber2012-03-13

Actions
Related to TYPO3 Core - Bug #45801: IE9: contextmenu-icons for next level not placed correctlyClosed2013-02-24

Actions
#1

Updated by Stefan Neufeind almost 9 years ago

Now I noticed I also can't click on any page in the pagetree. Menu and main BE-frame work fine though. So I guess that's some weird thing of my IE here locally.

If somebody else can open/close subtrees in the pagetree, then please close this bug as "not reproducible" since I guess it's a local IE-issue then.

#2

Updated by Michael Stucki almost 9 years ago

Seems like we have quite a lot of IE related pagetree issues. What can we do about it?

#3

Updated by Riccardo De Contardi over 8 years ago

Tested with
4.5.26: the bug is still present;
6.1.0: the bug is not present.

More in detail:

Browser Mode:IE9/Document Mode:IE8 (standard page value) : NO PROBLEM
Browser Mode:IE9/Document Mode:IE9 : BUG PRESENT
Browser Mode:IE8/Document Mode:IE8 : NO PROBLEM
Browser Mode:IE7/Document Mode:IE7 : NO PROBLEM

#4

Updated by Rupert Germann over 8 years ago

same here
IE9 in IE9 mode makes the pagetree unusable (no click possible)

the F12 Console shows this error:

SCRIPT16385: Not implemented

modernizr.min-502897bcb8b691f001cfeb2bdfa63d4a.js.gzip?1362747015, line 24 character 470

there's also a forum entry describing exact this issue:
http://forum.typo3.org/index.php/t/195839/

#5

Updated by Stefan Neufeind over 8 years ago

Core still ships with modernizr 1.6 (even in master, 6.2-pre).
Could you please try to exchange your modernizr-library and see if that helps? Clear all caches etc.

Latest I was able to find from 1.x was:
http://modernizr.com/downloads/modernizr-1.7.min.js

There seem to have been 1.8-something, but I couldn't find them for download.
A change to the 2.x-version might include other problems. But I'd like to see if choosing a newer 1.x might help.

#6

Updated by Jose Antonio Guerra over 7 years ago

Hi all,

Problem happens when IE's document mode is set to > IE8. If you force the document mode to be IE8 it works on IE9, IE10 and IE11 without problems.

The best way to force it is by forcing the web server to send the proper header on its HTTP response, here's a working config for Apache (you need to activate mod_headers):

<Location "/typo3">
   Header set X-UA-Compatible "IE=8" 
</Location>

Further info: http://msdn.microsoft.com/en-gb/cc817573.aspx

#7

Updated by Alexander Opitz over 7 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Can someone with this issue check if updating the version of modernizr.js helps? http://modernizr.com/downloads/modernizr-1.7.min.js

#8

Updated by Jose Antonio Guerra over 7 years ago

I've just realized that the backend is already rendering the proper meta tag to configure IE8 mode but it is being ignored:

alt_intro.php:

<!DOCTYPE html>
<html>
<head>
<!-- TYPO3 Script ID: typo3/alt_intro.php -->

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<title>About modules</title>
<meta name="generator" content="TYPO3 4.5, http://typo3.org/, &#169; Kasper Sk&#229;rh&#248;j 1998-2013, extensions are copyright of their respective owners." />
<meta name="robots" content="noindex,follow" />
<meta http-equiv="X-UA-Compatible" content="IE=8" />

[...]

According to the docs, the meta tags takes precedence over the HTTP header but in this case the meta is just being ignored, I've found more info here: http://stackoverflow.com/questions/10932881/html1115-x-ua-compatible-meta-tag-ie-9-ie-8-chrome-1-ignored-because-docu

#9

Updated by Jose Antonio Guerra over 7 years ago

There seems to be a lot of issues with Modernizr 1.x on IE9: https://github.com/Modernizr/Modernizr/issues/224

Version 1.x is quite old so I guess the best way to avoid problems is by updating.

#10

Updated by Jose Antonio Guerra over 7 years ago

Jose Antonio Guerra wrote:

There seems to be a lot of issues with Modernizr 1.x on IE9: https://github.com/Modernizr/Modernizr/issues/224

Version 1.x is quite old so I guess the best way to avoid problems is by updating.

Fixes of previous issue were only applied to versions 2.x of Modernizr:

https://github.com/Modernizr/Modernizr/commit/b51f17bb717bcbcfe3f918ff95c9ee33c6d3afc0

#11

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
#12

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from New to Closed

I've just tried with the demo site 6.2.9, on IE 9.0.8112.16421 and the pagetree works well. Even the demo of version 7 works (albeit it has a lot of other visualization issues), so I close this issue;

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF