Project

General

Profile

Actions

Bug #56351

closed

view page in another language than default language from Backend is incorrect

Added by zebulon no-lastname-given almost 10 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

When I try to view a content translated in another language than default language from Backend in list module I see only content in default language.

steps to reproduce in module list:

create a content in default language
add a translation of this content
on the content translated, do a right click then select "Show"
you will see only the content in default language

I have tried on 2 differents websites and problem is the same.

Tested on Typo3 version 4.5.32


Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #81386: Preview language setting not always setClosed2017-05-31

Actions
Related to TYPO3 Core - Bug #89531: Regression: "Show" in context menu for pages always shows root page on databases not casting return typesClosed2019-10-28

Actions
Related to TYPO3 Core - Bug #90124: PageProvider catches nonexisting ExceptionClosedDaniel Goerz2020-01-16

Actions
Related to TYPO3 Core - Bug #91087: Non-existing UnableToLinkToPageException in RecordProviderClosedChristian Eßl2020-04-17

Actions
Follows TYPO3 Core - Bug #48673: Changed language overlay behaviour in TYPO3 6.*Closed2013-05-30

Actions
Actions #1

Updated by Markus Klein over 9 years ago

If this still exists on 6.2 we need to ensure the link appends the target L parameter correctly.

Actions #2

Updated by Riccardo De Contardi over 8 years ago

still present in 6.2.14 and 7 (latest master)

Actions #3

Updated by Riccardo De Contardi almost 7 years ago

Still affects 8.7-dev (latest master); it works correctly on Info > localization overview.

Actions #4

Updated by Markus Klein almost 7 years ago

This problem is only present in the Click Menu of a content element.

On 7.6 the problem is that \TYPO3\CMS\Backend\ClickMenu\ClickMenu::printDBClickMenu() does not pass a language information to \TYPO3\CMS\Backend\ClickMenu\ClickMenu::DB_view() (which does not even have a parameter for this purpose).

The code in master has been fully rewritten, so this needs an extra check.

Actions #5

Updated by Riccardo De Contardi over 6 years ago

Still present on latest 9.0.0-dev (master); also affects the "View webpage" button in the page toolbar

Actions #6

Updated by Susanne Moog over 5 years ago

  • Sprint Focus set to On Location Sprint
Actions #7

Updated by Jasmina Ließmann over 5 years ago

I can confirm this issue on the current master (9.5.1-dev).

Actions #8

Updated by Susanne Moog over 5 years ago

  • Status changed from New to Needs Feedback

I cannot reproduce the issue on 9.5 - can you add new steps to reproduce?

I tested the following:

- Web > Page - Translated Content > Show in ClickMenu
- Web > List - Translated Page > Show via Icon
- Web > List - Translated Page > Show via ClickMenu
- Web > List - Translated Content > Show via Icon
- Web > List - Translated Content > Show via ClickMenu

With site configuration all tests use the correct language prefix (in my case /de/).
Without site configuration all tests add the L param (in my case L=4).

Actions #9

Updated by Riccardo De Contardi about 5 years ago

@Susanne Moog I tried with both 8.7.24 and 9.5.4; everything works fine Except:

- TYPO3 9.5.4
- List view > table "page translation" > right click on the icon of the translated page > show

Result:

Whoops, looks like something went wrong.

(1/1) #1518472189 TYPO3\CMS\Core\Error\Http\PageNotFoundException
The requested page does not exist

the problem is that the page that TYPO3 is trying to access is https://typo3.9.test.it:8890/eng-test (wrong) instead of the correct https://typo3.9.test.it:8890/en/eng-test it misses the /en/ part of the URL.

Can someone confirm? Should I open a new issue for that? Thank you

Actions #10

Updated by Jonas Eberle about 5 years ago

Riccardo De Contardi wrote:

- TYPO3 9.5.4
- List view > table "page translation" > right click on the icon of the translated page > show

the problem is that the page that TYPO3 is trying to access is https://typo3.9.test.it:8890/eng-test (wrong) instead of the correct https://typo3.9.test.it:8890/en/eng-test it misses the /en/ part of the URL.

Yes, I can confirm that. All the other "view" buttons I could find are calling the URL with the correct language prefix, but this right-click menu omits it.

Actions #11

Updated by Mona Muzaffar almost 5 years ago

  • Related to Bug #81386: Preview language setting not always set added
Actions #12

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61887

Actions #13

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61887

Actions #14

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61919

Actions #15

Updated by Christian Eßl over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Oliver Bartsch over 4 years ago

  • Related to Bug #89531: Regression: "Show" in context menu for pages always shows root page on databases not casting return types added
Actions #17

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions #18

Updated by Daniel Goerz about 4 years ago

  • Related to Bug #90124: PageProvider catches nonexisting Exception added
Actions #19

Updated by Christian Eßl almost 4 years ago

  • Related to Bug #91087: Non-existing UnableToLinkToPageException in RecordProvider added
Actions

Also available in: Atom PDF