Bug #61179

Epic #58282: Workspaces Workpackage #2

Story #58284: Bug fixes & Behaviour

Flaws in copying a page with localized content elements

Added by Oliver Hader about 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2014-08-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Scenario:
  • in Live Workspace
  • Page
  • content element for default language
  • content element localization with reference to the default record
Action:
  • in Draft Workspace
  • copy the mentioned page
Experience:
  • copy process works
  • open new inserted page on Web>List module
  • translation for the content element is not shown
Reason:
  • the translation pointer value for the new placeholder is not updated and still points to the record of the origin page

Files

source-page-from-live-ws.png (141 KB) source-page-from-live-ws.png Daniel Goerz, 2015-08-21 23:09
copy-of-page-in-ws.png (149 KB) copy-of-page-in-ws.png Daniel Goerz, 2015-08-21 23:09
CloningResultInDraftWorkspace.png (84.3 KB) CloningResultInDraftWorkspace.png Second cloning result of page (53) in draft workspace (1) Oliver Hader, 2015-08-22 11:23

Related issues

Related to TYPO3 Core - Task #68395: Make CE copy action more flexibleClosedAndreas Fernandez2015-07-20

Actions
Related to TYPO3 Core - Bug #64939: Copying a translated page in Workspace duplicates the first content elementClosed2015-02-09

Actions
Related to TYPO3 Core - Bug #64941: Display of translation after copying a page in workspaceClosed2015-02-09

Actions

Also available in: Atom PDF