Bug #71164

ImageManipulation Using in Page Resources Media Relation

Added by Janine Schendel about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Image Generation / GIFBUILDER
Target version:
-
Start date:
2015-10-30
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hey Team,

while using Image Manipulation in Pages -> Resources as Media Relation, nothing changes to images in frontend.

In our case, we would like to have a fixed size of image, but the extract should be positioned by image manipluation.

TS looks like:

lib.headerimage = FILES
lib.headerimage {
    references {
        table = pages
        uid.data = tsfe:id
        #uid.data = leveluid: -1, slide
        fieldName = media
    }
    renderObj = COA
    renderObj.10 = IMAGE
    renderObj.10 {
        file.import.data = file:current:publicUrl
        file.width = 1920c
        file.height = 757c
        altText.data = file:current:title
        wrap = <div class="taller-img">|</div>
    }
}

Do we miss something in TS to get image manipulation working?

imageManipulation.png View - TS Setup with file:current:crop (16.4 KB) Janine Schendel, 2015-10-30 16:12

imageManipulation_BE.png View - Change Position in BE Page (21.7 KB) Janine Schendel, 2015-10-30 16:12

imageManipulation_FE.png View - Look @ FE Image (806 KB) Janine Schendel, 2015-10-30 16:12

imageManipulation_BEchange.png View - Change Position in BE again (28.7 KB) Janine Schendel, 2015-10-30 16:12

imageManipulation_FEchange.png View - Look @ FE after second change (803 KB) Janine Schendel, 2015-10-30 16:12


Related issues

Related to TYPO3 Core - Bug #82057: file:current:crop does not work anymore for page media resources Closed 2017-08-08

History

#1 Updated by Oliver Hader about 4 years ago

Hi Janine,

without having it tested, adding a file.crop.data = file:current:crop to your renderObj.10 section should do the trick. Just let me know whether that works out on your side...

#2 Updated by Frank Naegler about 4 years ago

Hi Janine,
yes, you miss the cropping settings.

Please see the rst file for this feature: https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/7.2/Feature-65584-AddImageCropping.html

All you need is this line in your setup: file.crop.data = file:current:crop

Complete example with the additional line:

lib.headerimage = FILES
lib.headerimage {
    references {
        table = pages
        uid.data = tsfe:id
        #uid.data = leveluid: -1, slide
        fieldName = media
    }
    renderObj = COA
    renderObj.10 = IMAGE
    renderObj.10 {
        file.crop.data = file:current:crop
        file.import.data = file:current:publicUrl
        file.width = 1920c
        file.height = 757c
        altText.data = file:current:title
        wrap = <div class="taller-img">|</div>
    }
}

If this helps, please give us a short feedback, that we can close this issue.

#3 Updated by Frank Naegler about 4 years ago

:D Olli was faster, @Olliver: yes this is the solution ;)

#4 Updated by Frank Naegler about 4 years ago

  • Status changed from New to Needs Feedback

#5 Updated by Janine Schendel about 4 years ago

hey, added the line, but still not working.

Nothing happens to FE Image after changing the positions.
Currenty working with 7.4 t3sbootstrap 2.1.1

see attachments.

regards and nice weekend
Janine

#6 Updated by Janine Schendel almost 4 years ago

Hey, only diffence i can see betwenn you snippet and my screenshot is

renderObj.10 = IMAGE --> your code

and

renderObj.10 = IMG_RESOURCE --> my code

changed my code to IMAGE, but crop does not work!

tested your snippet, cropping does not work for me.

#7 Updated by Alexander Opitz over 3 years ago

  • Status changed from Needs Feedback to New

#8 Updated by Josef Glatz about 2 years ago

  • Related to Bug #82057: file:current:crop does not work anymore for page media resources added

#9 Updated by Peter Kraume about 2 years ago

This problem still exists in TYPO3 7.6.23.

#10 Updated by Susanne Moog about 2 years ago

  • Category changed from Image Cropping to Image Generation / GIFBUILDER

#11 Updated by Benni Mack almost 2 years ago

lib.headerimage = FILES
lib.headerimage {
    references {
        table = pages
        uid.data = tsfe:id
        #uid.data = leveluid: -1, slide
        fieldName = media
    }
    renderObj = IMAGE
    renderObj {
        file.crop.data = file:current:crop
        file.import.data = file:current:uid
        file.import.treatIdAsReference = 1
        file.width = 1920c
        file.height = 757c
        altText.data = file:current:title
        wrap = <div class="taller-img">|</div>
    }
}

Shouldn't "treatIdAsReference = 1" be added as in the example as above?

#12 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Hi, sorry for this late answer; did the suggestion by Frank and Benni solved your issue? If not, could you provide an example? Thank you!

#13 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or the suggestions did not help you or experience the issue again, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF