Bug #82750

Workspace preview doesn't preview MM relations properly

Added by Lorenz Ulrich over 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-10-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the workspace preview is used to preview a record of an Extbase extension having an m:n relation, the relation data isn't displayed properly in the stage preview.

The stage preview doesn't show a relation added to an item in a workspace while it is correctly saved in the database and also correctly applied if published.

So I assume the reason for the preview not working properly must be a bug in Extbase.

I created an extension to demonstrate the issue:

https://github.com/visol/ext-group_mm_workspaces_test

The Workspace preview only works in this case if https://review.typo3.org/#/c/52791/ is applied.


Related issues

Related to TYPO3 Core - Bug #81208: Invalid SQL query when previewing a workspace with translated relationsClosedBenni Mack2017-05-12

Actions
Related to TYPO3 Core - Bug #85061: Extbase doesn't overlay workspace recordsClosedNicole Cordes2018-05-22

Actions

Also available in: Atom PDF