Bug #81208

Invalid SQL query when previewing a workspace with translated relations

Added by Xavier Perseguers over 4 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extbase + l10n
Target version:
-
Start date:
2017-05-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
uid_local
Complexity:
Is Regression:
Sprint Focus:

Description

DISCLAIMER

This is quite tricky and could not understand how to reproduce it in a vanilla install.

Context

  • The problem happens for me when previewing a page from a workspace with a menu of categories associated to EXT:news records.
  • In my case I have a custom extended domain model for news records but it does not seem to be related, I removed corresponding columns/fields from the query below

Preview crashes with:

An exception occurred while executing 'SELECT `uid_local`, `uid_foreign`, `tablenames`, `sorting`, `sorting_foreign`, `fieldname`, `uid`, `pid`, `tstamp`, `crdate`, `cruser_id`, `deleted`, `hidden`, `starttime`,
`endtime`, `t3ver_oid`, `t3ver_id`, `t3ver_wsid`, `t3ver_label`, `t3ver_state`, `t3ver_stage`, `t3ver_count`, `t3ver_tstamp`, `t3ver_move_id`, `t3_origuid`, `sys_language_uid`, `l10n_parent`, `l10n_diffsource`,
`title`, `description`, `parent`, `items`, `fe_group`, `images`, `single_pid`, `shortcut`, `import_id`, `import_source`, `seo_title`, `seo_description`, `seo_headline`, `seo_text`, `l10n_state`
FROM `sys_category` WHERE (`pid` = ?) AND (`t3ver_oid` = ?) AND (`t3ver_wsid` = ?) AND (`sys_category`.`deleted` = 0) LIMIT 1' with params [-1, 29, 2]: Unknown column 'uid_local' in 'field list' 

Call stack shows:

After quite some deep debugging, I could understand the context:

  • This happens when the rows array which need to be overlaid in \TYPO3\CMS\Extbase\Persistence\Generic\Storage\Typo3DbBackend::doLanguageAndWorkspaceOverlay() are the result of a JOIN (in my case a JOIN from sys_category and sys_category_record_mm
  • Each row is thus containing fields coming from both tables
  • The test on $source at the beginning of method doLanguageAndWorkspaceOverlay properly detects that a JOIN is in use and extracts the right table (sys_category)
  • There are some tests whether the "original" record needs to be fetched, for instance when a move is detected, that's not invoked in my case
  • There is another test which detects that current record is a translation already and then would fetch the parent record instead, this is where the problem lies
  • If current record is a default language record AND we are in the context of fetching the content of a workspace (method is invoked multiple times with same record causing no errors until the context of the call is the actual workspace preview), then it bypasses the action of reloading the record from database
  • Since it bypasses this reload, call to versionOL is made with a row containing additional columns from sys_category_record_mm and since the test at the very beginning of method versionOL succeeds, there is a call to method getWorkspaceVersionOfRecord with those invalid additional columns and this is the source of the SQL failure

Solution Found

The test to reload the original record is extended to check if we are in the context of a workspace preview and if so, ensure no additional columns are present


Files

stacktrace.png (182 KB) stacktrace.png Xavier Perseguers, 2017-05-12 12:01
kittensftw.zip (20.1 KB) kittensftw.zip extension (kittensftw) Susanne Moog, 2018-03-07 14:02
T3D_tree_PID201_L0_2018-03-07_13-01.t3d (8.23 KB) T3D_tree_PID201_L0_2018-03-07_13-01.t3d example page t3d export Susanne Moog, 2018-03-07 14:02
81208_v9.diff (7.74 KB) 81208_v9.diff Ralf Merz, 2019-10-08 15:46
81208_v9.5.diff (5.34 KB) 81208_v9.5.diff Markus Hackel, 2020-04-27 13:09

Related issues

Related to TYPO3 Core - Bug #82750: Workspace preview doesn't preview MM relations properlyClosed2017-10-12

Actions
Related to TYPO3 Core - Feature #90072: Make inline TCA fields workspace-transparent for Extbase (foreign_field and foreign_sortby)Needs Feedback2020-01-09

Actions
Related to TYPO3 Core - Bug #85061: Extbase doesn't overlay workspace recordsClosedNicole Cordes2018-05-22

Actions
#1

Updated by Xavier Perseguers over 4 years ago

  • Description updated (diff)

Added new lines to SQL to make it more readable

#2

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52791

#3

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52791

#4

Updated by Michael Kasten about 4 years ago

Can confirm this bug, same Problem here with TYPO3 8.7.4 and News.

I see, here is a patch, and it will be revied.. since four months, what is the plan here?

Any information about in which release ore when this patch should be available?

We have two big TYPO3 Installation, ready to go online, no chance to patch the core with my self (no permission at this hosting)

Any other hints?

best regards

#5

Updated by Xavier Perseguers about 4 years ago

Hey Michael,

Since you face the very same problem, I would suggest to test the patch to see if it works properly and then give a feedback in the form of a review, following the link to the review system (same credentials as for here).

A patch is good but if nobody confirms the bug and reports that the patch indeed fixes the problem, then it's unlikely to be merged on its own...

#6

Updated by Christian Weiske about 4 years ago

The patch helps here.

#7

Updated by Andreas Kokott about 4 years ago

In my case the patch did not help.
The columns of my custom _mm table are still applied to the query.

#8

Updated by Gerrit Code Review almost 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52791

#9

Updated by Gerrit Code Review almost 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52791

#10

Updated by Sascha no-lastname-given almost 4 years ago

I have the same problem.

The last patch works for me.

#11

Updated by Cristian Buja over 3 years ago

The last patch works for me too.

#12

Updated by Oliver Hader over 3 years ago

To continue on this issue, I'd kindly like to ask for a step-by-step documentation on how to reproduce the behavior - which scenario is required for that?

#13

Updated by Susanne Moog over 3 years ago

Attached is a test extension I just generated with the extension builder and a t3d export of a page which reproduces the error.

Steps (without the t3d export, manually done)

- Extract example extension "kittensftw" and install it
- Create a new page
- Create a content element on the page - choose the plugin from the example extension and use the current page as starting point
- Create a category on the page
- Create an example extension record ("kitten") on the page and assign the category
- Preview (without workspace) in frontend: you should see a list view with your record
- Switch to workspace
- DO NOT change anything
- Preview same page -> Exception


Uncaught TYPO3 Exception
An exception occurred while executing 'SELECT `uid_local`, `uid_foreign`, `tablenames`, `fieldname`, `sorting`, `sorting_foreign`, `uid`, `pid`, `tstamp`, `crdate`, `cruser_id`, `deleted`, `hidden`, `starttime`, `endtime`, `t3ver_oid`, `t3ver_id`, `t3ver_wsid`, `t3ver_label`, `t3ver_state`, `t3ver_stage`, `t3ver_count`, `t3ver_tstamp`, `t3ver_move_id`, `t3_origuid`, `sys_language_uid`, `l10n_parent`, `l10n_diffsource`, `title`, `description`, `parent`, `items`, `l10n_state`, `fe_group`, `images`, `single_pid`, `shortcut`, `import_id`, `import_source`, `seo_title`, `seo_description`, `seo_headline`, `seo_text` FROM `sys_category` WHERE (`pid` = ?) AND (`t3ver_oid` = ?) AND (`t3ver_wsid` = ?) AND (`sys_category`.`deleted` = 0) LIMIT 1' with params [-1, 7, 1]: Unknown column 'uid_local' in 'field list'
#14

Updated by Dennis Metz over 3 years ago

Got the exact same problem.

Last patch is working for me too.

#15

Updated by Frédéric Lebel over 3 years ago

We have the same problem here.

The patch works for us.

#16

Updated by Dennis Metz over 3 years ago

Hey guys,
is there anything new about this?

We really need this fix...

#17

Updated by Gianluca Strafella over 3 years ago

Last patch works fine with TYPO3 8.7.15.

#18

Updated by Tymoteusz Motylewski about 3 years ago

  • Related to Bug #82750: Workspace preview doesn't preview MM relations properly added
#19

Updated by Gerrit Code Review almost 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52791

#20

Updated by Marcos Fadul over 2 years ago

I've having this issue also with not translated content.

We are using typo3 8.7.20 with Flux and Blog extension. Previewing the default language is generation the same error.

We are using the patch #4. It fixed part of the problem.

#21

Updated by Franz Koch over 2 years ago

facing the same issue. Patchset 5 unfortunately no longer applies due to small changes related to TYPO3 context and workspaceID, but applying the changes from the patchset manually did unfortunately not solve the issue for me (or maybe I messed it up somehow).

#22

Updated by Torben Hansen over 2 years ago

The problem is still valid in TYPO3 9.5 LTS. I'm facing the problem in a project with models that have simple mm relations to sys_categories and also with a mm relations to a custom model.

In a fresh TYPO3 website, the problem is also reproducible with Susis demo extension mentioned in #81208#note-13

Update: It seems, that $pageRepository->versionOL($tableName, $row, true); in overlayLanguageAndWorkspace is causing the exception.

#23

Updated by Kai Tallafus about 2 years ago

Can confirm this still happens in V9.5. Using events2 Extension, which has a flexform with sys_category tree multiselect.

#24

Updated by Jakob Berlin about 2 years ago

  • Category changed from Extbase to Extbase + l10n
  • Priority changed from Should have to Must have
  • TYPO3 Version changed from 8 to 9
  • PHP Version set to 7.2
  • Tags set to uid_local

also still have this problem in a TYPO3 9.5.5 with news 7.1 installation :(

#25

Updated by Ralf Merz almost 2 years ago

Hi,

I also run into this error on TYPO3 9.5.9 with

"t3g/blog": "^9.1",

installed.
I cannot preview a blog page having a category assigned in workspace.

Getting same exception:

An exception occurred while executing 'SELECT `uid_local`, `uid_foreign`, `tablenames`, `fieldname`, `sorting`, `sorting_foreign`, `uid`, `pid`, `tstamp`, `crdate`, `cruser_id`, `deleted`, `hidden`, `starttime`, `endtime`, `t3ver_oid`, `t3ver_id`, `t3ver_wsid`, `t3ver_label`, `t3ver_state`, `t3ver_stage`, `t3ver_count`, `t3ver_tstamp`, `t3ver_move_id`, `t3_origuid`, `sys_language_uid`, `l10n_parent`, `l10n_diffsource`, `title`, `description`, `parent`, `items`, `fe_group`, `images`, `single_pid`, `shortcut`, `import_id`, `import_source`, `seo_title`, `seo_description`, `seo_headline`, `seo_text`, `l10n_state`, `slug`, `content`, `posts` FROM `sys_category` WHERE (`pid` = ?) AND (`t3ver_oid` = ?) AND (`t3ver_wsid` = ?) AND (`sys_category`.`deleted` = 0) LIMIT 1' with params [-1, 2, 1]: Unknown column 'uid_local' in 'field list'

Are there any news on this?
Will try to debug...

Thx
merzilla

#26

Updated by Xavier Perseguers almost 2 years ago

Hello Ralf,

Are there any news on this?
Will try to debug...

No need to debug, just check the patch I created ... 2 years ago :)

#27

Updated by Ralf Merz almost 2 years ago

Xavier Perseguers wrote:

Hello Ralf,

Are there any news on this?
Will try to debug...

No need to debug, just check the patch I created ... 2 years ago :)

Hi Xavier,

i have just testet PS 5, but it does not apply to v9 out of the box.
I´ll have a look in the extbase code and try to apply it manually.

Thanks for your fast reply!

Cheers
Ralf

#28

Updated by Ralf Merz almost 2 years ago

As I could see now for v9 we need to also patch function overlayLanguageAndWorkspace() in Typo3DbBackend.php as "consistentTranslationOverlayHandling" is enabled by default in v9 and will be always on in v10.

See: https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/9.5/Important-82363-MakeExtBaseTranslationHandlingConsistentWithTyposcript.html

#29

Updated by Ralf Merz almost 2 years ago

Hi guys,

I've added the patch manually to extbase in v9.5.9.
So the patch mainly is for doLanguageAndWorkspaceOverlay(), but I've now also added it to overlayLanguageAndWorkspace() in devil's line 666 ;)

We use PHP 7.3, but this should not be an issue.

Can someone please try this out?
I do not exactly remember to push it to gerrit... have to read guidelines again first to be able to push for v9... :( sorry. But I guess I am able to give it a try today.

Cheers
merzilla

#30

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#31

Updated by Ralf Merz almost 2 years ago

Gerrit Code Review wrote:

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

I've implemented the patch now also in the master branch. HTH and will fix this preview bug for you, too.

#32

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#33

Updated by Lukas Speck almost 2 years ago

Gerrit Code Review wrote:

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

The Patch has a bug in the line 741. If a workspace ist active and $forceRecordReloadInWorkspace is true, $row is replaced by a result where 'l10n' (or $GLOBALS['TCA'][$tableName]['ctrl']['transOrigPointerField']) is qual to uid. But this field could be 0 and then the result is "false".
I fixed it with this line in line mentioned:

$row[$GLOBALS['TCA'][$tableName]['ctrl']['transOrigPointerField']] == 0 ? $row['uid'] : $row[$GLOBALS['TCA'][$tableName]['ctrl']['transOrigPointerField']]

Cheerio Lukas

#34

Updated by Kurt Gusbeth over 1 year ago

I had the same problem with an own extension (which uses TYPO3 categories) and the patch
https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791
fixed it, but there is no line 741 to see in the patch.
Lukas, can you tell, which code should be replaced?
It is an old "Must have" bug and it is still not fixed in TYPO3 9.5.14...

#35

Updated by Dave Zen over 1 year ago

I have the same error (again, I think). It could be that this happened before with another extensions, the bug sounds familiar.

It happens in 9.5.15 and blog 9.1.2 when I want to preview the blog list or a plog post in workspaces in the german language (which is the default language). I translated the page into english and there the preview seems to work.

(1/2) Doctrine\DBAL\Exception\InvalidFieldNameException

An exception occurred while executing 'SELECT `uid_local`, `uid_foreign`, `tablenames`, `fieldname`, `sorting`, `sorting_foreign`, `uid`, `pid`, `tstamp`, `crdate`, `cruser_id`, `deleted`, `hidden`, `starttime`, `endtime`, `t3ver_oid`, `t3ver_id`, `t3ver_wsid`, `t3ver_label`, `t3ver_state`, `t3ver_stage`, `t3ver_count`, `t3ver_tstamp`, `t3ver_move_id`, `t3_origuid`, `sys_language_uid`, `l10n_parent`, `l10n_diffsource`, `title`, `description`, `parent`, `items`, `fe_group`, `images`, `single_pid`, `shortcut`, `import_id`, `import_source`, `seo_title`, `seo_description`, `seo_headline`, `seo_text`, `content`, `l10n_state`, `posts`, `slug` FROM `sys_category` WHERE (`pid` = ?) AND (`t3ver_oid` = ?) AND (`t3ver_wsid` = ?) AND (`sys_category`.`deleted` = 0) LIMIT 1' with params [-1, 354, 1]: Unknown column 'uid_local' in 'field list'

in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 60

in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php line 166
in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php line 146
in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php line 912
in /var/www/html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Query/QueryBuilder.php line 206
in /var/www/html/web/typo3/sysext/core/Classes/Database/Query/QueryBuilder.php line 187
in /var/www/html/web/typo3/sysext/frontend/Classes/Page/PageRepository.php line 2024
in /var/www/html/web/typo3/sysext/frontend/Classes/Page/PageRepository.php line 1819
...

Has someone a patch for v9.5.15?

#36

Updated by Xavier Perseguers over 1 year ago

Not me, reported with a suggested fix 3 years ago, Susanne wrote a test extension 2 years ago, does not seem to ring a bell to be finally tackled with, I personally don't need it (yet) since I'm still on v8 for the 2 big websites I would possibly need it. Just hope that someone is finally taking care.

#37

Updated by Markus Hackel over 1 year ago

Lukas Speck wrote:

Gerrit Code Review wrote:

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

The Patch has a bug in the line 741. If a workspace ist active and $forceRecordReloadInWorkspace is true, $row is replaced by a result where 'l10n' (or $GLOBALS['TCA'][$tableName]['ctrl']['transOrigPointerField']) is qual to uid. But this field could be 0 and then the result is "false".
I fixed it with this line in line mentioned:
[...]

Cheerio Lukas

I can provide a patch for TYPO3 9.5 which works for me and also implements the fix mentioned in Lukas' comment.

Since the affected class has some more changes in v10 I will have a closer look to provide this fix there too. But I hope to be able to push it to Gerrit soon.

#38

Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64333

#39

Updated by Gerrit Code Review over 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#40

Updated by Markus Hackel over 1 year ago

Gerrit Code Review wrote:

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64333

Please forget about this one. I accidentally created a new patchset initially.

#41

Updated by Markus Hackel over 1 year ago

Gerrit Code Review wrote:

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

Above patch you can test in v10 with Susanne's EXT:kittensftw attached to this ticket.

For v9.5 you can still try the 81208_v9.5.diff.

#42

Updated by Gerrit Code Review over 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#43

Updated by Ingo Fabbri over 1 year ago

Ralf Merz wrote:

Hi guys,

I've added the patch manually to extbase in v9.5.9.
So the patch mainly is for doLanguageAndWorkspaceOverlay(), but I've now also added it to overlayLanguageAndWorkspace() in devil's line 666 ;)

We use PHP 7.3, but this should not be an issue.

Can someone please try this out?
I do not exactly remember to push it to gerrit... have to read guidelines again first to be able to push for v9... :( sorry. But I guess I am able to give it a try today.

Cheers
merzilla

81208_v9.5.diff works for me in 9.5.17. Great! But PS9 seems to be broken - I cannot apply it on v9.

#44

Updated by Ingo Fabbri over 1 year ago

I did not use workspaces for years. Just to enable the feature on a v9 installation. Of course it yelled out big fat Whoooops whoops an error occured. Now I am here. 2020 - with a quite old issue still unresolved - even though several ways to reproduce the issue were provided. even a patch. I'll try to fix the PS9 so it may merge again on v9 and master. holy batman

#45

Updated by Gerrit Code Review over 1 year ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#46

Updated by Ingo Fabbri about 1 year ago

Gerrit Code Review wrote:

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

Patch set 10 does not fix the issue. 81208_v9.5.diff is still the way to go - at least to get rid of the exception. 81208_v9.5.diff still does not get it right with sys_category - but at least the frontend does not break.

#47

Updated by Benni Mack about 1 year ago

  • Related to Feature #90072: Make inline TCA fields workspace-transparent for Extbase (foreign_field and foreign_sortby) added
#48

Updated by Benni Mack about 1 year ago

  • Related to Bug #85061: Extbase doesn't overlay workspace records added
#49

Updated by Jonathan Starck 11 months ago

  • TYPO3 Version changed from 9 to 10
  • PHP Version changed from 7.2 to 7.4

I also got this error in TYPO3 Version 10 on PHP 7.4 via Composer

#50

Updated by Carsten Hülsmann 11 months ago

Jonathan Starck wrote:

I also got this error in TYPO3 Version 10 on PHP 7.4 via Composer

Same issues here.
The patch did work but due to another patch (https://review.typo3.org/c/Packages/TYPO3.CMS/+/57012) it doesn't anymore.

#51

Updated by Gerrit Code Review 10 months ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#52

Updated by Gerrit Code Review 10 months ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#53

Updated by Carsten Hülsmann 10 months ago

  • Assignee changed from Xavier Perseguers to Benni Mack

I gave it another try - less complex.
The original idea is kept and I just extended the changes Benni did already for languageOverlays but extended this also in case we're in workspace context to get rid of the additional columns here as well.

#54

Updated by Gerrit Code Review 10 months ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#55

Updated by Gerrit Code Review 10 months ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#56

Updated by Gerrit Code Review 10 months ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#57

Updated by Gerrit Code Review 10 months ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#58

Updated by Gerrit Code Review 10 months ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/52791

#59

Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66732

#60

Updated by Hercules Karvasonis 10 months ago

Hi all.

The latest patch above is fixing the issue for me in the latest TYPO3 10.4.10.

Thanks a lot!

Hercules.

#61

Updated by Alexander Rotzsch 7 months ago

With patch 66732 the error (only on blog pages in my case) is gone. Testet with 10.4.13. Please cherry pick. :)

#62

Updated by Gerrit Code Review 5 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68915

#63

Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68915

#64

Updated by Gerrit Code Review 5 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68915

#65

Updated by Gerrit Code Review 5 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68935

#66

Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68935

#67

Updated by Gerrit Code Review 5 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68915

#68

Updated by Benni Mack 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#69

Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF