Bug #85099

Epic #90674: Backend UI not reflecting permissions

Attempt to delete without permission - error message shows up, but action works

Added by Ralf Merz over 3 years ago. Updated over 1 year ago.

Status:
On Hold
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2018-05-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
#30229
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

I have to notice that issue #30229 still not solved completely.
https://forge.typo3.org/issues/30229

If an editor (non-admin) deletes a page in the page tree (e.g. via context menu), AND that page as at least 1 translation (alternative page language) and a translated element on it (see attachment), then the red flashMessage "1: Attempt to delete record without delete-permissions" (see attachment).
I have checked the "Access" Module: What we have set is a "770" for the pages (see attachment).
It does not matter if the editor has created the page (and translation) or an admin did that.

The reloaded page tree then shows that the page has been deleted anyways. But because of the error message, the editor thinks his action went wrong.

TYPO3 8.7.15

As mentioned in issue #30229 I must reopen this bug with this issue.

Thank you for taking care and regards
Ralf - merzilla


Files

Bildschirmfoto 2018-05-28 um 16.31.15.png (8.94 KB) Bildschirmfoto 2018-05-28 um 16.31.15.png Error Message Ralf Merz, 2018-05-28 16:38
Bildschirmfoto 2018-05-28 um 16.30.48.png (51.5 KB) Bildschirmfoto 2018-05-28 um 16.30.48.png Translated page Ralf Merz, 2018-05-28 16:38
Bildschirmfoto 2018-05-28 um 16.34.03.png (15.6 KB) Bildschirmfoto 2018-05-28 um 16.34.03.png Access Rights Ralf Merz, 2018-05-28 16:38

Related issues

Related to TYPO3 Core - Bug #30229: Error when deleting a Page with translationClosed2011-09-23

Actions

Also available in: Atom PDF