Bug #18429

required fields in Flexform are not correct marked with Exclamation Sign

Added by Steffen Kamper almost 12 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2008-03-12
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In TCEForms required fields are marked with the yellow Exclamation Sign, also the Tabs containing those fields.

If a TCEForm contains a flexform with tabs and required fields, they are not marked.
If there is one required field inside: only complete flexform is marked with Exclamation Sign
If there are more than one required fields inside, no field is marked.
The fields insifde Flexforms are never marked.

If fields in Flexform are IRRE records the required check will fail also because the naming of the field is different then in the form.

to reproduce it look at pbsurvey which has required fields in flexform as IRRE fields
(issue imported from #M7832)

0007832.patch View (4.88 KB) Administrator Admin, 2008-03-17 18:01


Related issues

Related to TYPO3 Core - Bug #18427: Required fields within flexform section elements cause Javascript errors Closed 2008-03-11
Related to TYPO3 Core - Bug #18751: JavaScript error in TBE_EDITOR causes login expired dialog Closed 2008-05-06
Related to TYPO3 Core - Bug #47372: Problem with enforcing an image in a news record. Closed 2013-04-19
Duplicated by TYPO3 Core - Bug #21894: Flexforms: no exclamation mark for required fields Closed 2009-12-29
Duplicated by TYPO3 Core - Feature #17900: Marking required fields in flexforms Rejected 2007-12-09
Duplicated by Dynamic Content Elements (DCE) - Bug #59702: obligatory fields Closed 2014-06-20
Blocked by TYPO3 Core - Bug #17122: flexform <eval>required</eval> on type "input" applies only on last input-field Closed 2007-03-15

History

#1 Updated by Steffen Kamper almost 12 years ago

Now i know that this isn't IRRE. It's Kaspers new flexform arrays, unfortunally this is not documented anywhere.

#2 Updated by Oliver Hader almost 12 years ago

The attached patch is just a beginning, it adds the flexform sheets/tabs to the stack of nested elements.

Next steps:
  • add required-icon to each field of a flexform block
  • extend the required nested checks to use flexform sheets (=tabs) and fields
  • really remove flexform sections (currently they are only hidden and not removed)
  • create a better handling for adding/removing dynamic flexform secions
    -> add: register some stuff in JavaScript
    -> remove: ensure that no other part relies on a removide flexform section

#3 Updated by Lina Wolf over 9 years ago

Duplicate of 0013117 witch has some sponsoring

#4 Updated by Steffen Kamper over 9 years ago

i don't see any sponsoring there ;)

#5 Updated by Steffen Kamper over 9 years ago

olly did some investigations and i looked to this yesterday too. From my debugs, the flexform field is in the nested stackes. I used this debug in line 202:
if (autoNotify) {
console.log(elementData, elementName);

which showed that the required field in in elementName. Only the elementData is the complete flexform.
Imho this is because of the recursive render of flexforms in t3lib_tceforms.

2 things have to be done:
1) fields in flexform also need the rec_ and cm_ image rendered in front
2) the field has to be added to the stack (see olly's patch)

then the javascript will work as expected and the correct image will be set.

#6 Updated by Jerome BLUM over 8 years ago

This bug is still present in TYPO3 4.4. The patch is no longer compatible with this version.

#7 Updated by Christian Weiske about 7 years ago

When #17122 is fixed, this issue is fixable.

#8 Updated by Lars no-lastname-given over 6 years ago

Nothing happend here until today...

#9 Updated by most wanted about 6 years ago

We just tested it with the current master and can confirm that this applies also for TYPO3 6.2.

Fields configured with 'eval' is set to 'required' are not marked with exclamation mark and the record can be saved even if the field is not filled with data.

Exception: last input field (see #17122)

#10 Updated by Alexander Stehlik almost 6 years ago

It also seems to affect group fields with a configured minitems value.

The FlexForm can not be saved (JavaScript alert about missing fields pops up) but no exclamation mark is visible.

#11 Updated by Rares Luca over 5 years ago

Alexander Stehlik wrote:

It also seems to affect group fields with a configured minitems value.

The FlexForm can not be saved (JavaScript alert about missing fields pops up) but no exclamation mark is visible.

I can confirm this too on TYPO3 6.2.1, but I can see the exclamation marks!
(If I remove the minitems from the flexform, the issue is gone)

#12 Updated by Michael Voehringer almost 5 years ago

Alexander Stehlik wrote:

It also seems to affect group fields with a configured minitems value.

The FlexForm can not be saved (JavaScript alert about missing fields pops up) but no exclamation mark is visible.

I can also confirm this behave of the validation issue with filefields with an minitems of 1. I found another bug #47372 which fixes the same error with TCA-objects, but the fix did not work for flexforms.

#13 Updated by Alexander Opitz over 4 years ago

  • Description updated (diff)
  • Category set to Backend User Interface
  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

What the state of this issue?
Does it still happen with TYPO3 CMS 6.2.14?

#14 Updated by Lorenz Ulrich over 4 years ago

Alexander Opitz wrote:

What the state of this issue?
Does it still happen with TYPO3 CMS 6.2.14?

Yes. There was no improvement in TYPO3 6.2 regarding this bug.

#15 Updated by Christian Kuhn over 4 years ago

this will probably not fixed in 6.2 anymore. there was a lot of effort in 7 to improve the required handling and it is not possible to backport this stuff to 6.2.

#16 Updated by Christian Kuhn over 4 years ago

verified: this is fixed in 7, but will not be changed in 6.2. i'll close the issue as 'won't fix' for 6.2 now.

#17 Updated by Christian Kuhn over 4 years ago

  • Status changed from Needs Feedback to New

#18 Updated by Christian Kuhn over 4 years ago

  • TYPO3 Version changed from 4.2 to 6.2
  • PHP Version changed from 5.2 to 5.3

#19 Updated by Christian Kuhn over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF