Bug #44645

Preview images don't get a new filename after overwriting with updated file

Added by Marcel Burkhalter over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-01-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:
- Upload a file in the filelist
- Check filename of preview image (e.g.: preview_102455_4635_924f2e40ad.jpg)
- Overwrite with a file with the same filename but different file content
- Check preview filename again --> it stays the same
--> We've seen caching issues with IE9 because of this

As a workaround we added the following config in the .htaccess file:

<FilesMatch "^preview_.*\.(jpe?g|png|gif)$">
  FileETag none
  <ifModule mod_headers.c>
    Header unset ETag
    Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate" 
    Header set Pragma "no-cache" 
    Header set Expires "Wed, 11 Jan 1984 05:00:00 GMT" 
  </ifModule>
</FilesMatch>

This worked for the filelist: we now see the correct preview image directly after overwriting without manual browser reload or browser cache clearing.
BUT: In the list or page module we still see the old preview image until the IE9 tab has been reloaded (without the .htaccess rule we had to clear the browser cache to see the updated preview image). Of course this all works flawlessly with FF :)


Related issues

Related to TYPO3 Core - Task #44550: Preview image and database entry not deleted when deleting a FAL fileClosed2013-01-15

Actions
Related to TYPO3 Core - Bug #44073: Checksum needs to be updated after file processingClosed2012-12-17

Actions
Related to TYPO3 Core - Bug #44105: Image size does not get updatedClosed2012-12-19

Actions
Related to TYPO3 Core - Bug #56539: Update/Change file-hash when file is replaced with a new one with the filelistClosed2014-03-04

Actions

Also available in: Atom PDF