Feature #56133

Replace file feature for fal file list

Added by Bernhard Eckl over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-02-19
Due date:
% Done:

100%

PHP Version:
5.3
Tags:
Complexity:
Sprint Focus:

Description

Actually I use TYPO3 4.7 with DAM because of the need of the feature, a button to replace a file (new file upload, gets renamed to old filename on the server). Neither TYPO3 6.2 has this feature yet, nor the media extension.

media_extension_replace_file.jpg View (23.1 KB) Tobias Schaefer, 2015-04-21 16:56


Related issues

Related to TYPO3 Core - Task #56147: Regenerate missing RTE magic image on rendering Closed 2014-02-20
Related to TYPO3 Core - Feature #48644: Easy way to replaceReferences Accepted 2013-05-29
Related to TYPO3 Core - Feature #66514: Better UI to move multiple files or folders New 2015-04-21
Related to TYPO3 Core - Bug #68260: FOLLOW-UP Replace file feature for fal file list Closed 2015-07-16
Related to TYPO3 Core - Task #77474: Doctrine: Migrate remaining easy UpdateWizards Closed 2016-08-10
Related to TYPO3 Core - Bug #77500: FilesReplacePermissionUpdate broken Closed 2016-08-14
Related to TYPO3 Core - Bug #78896: Replace file feature for FAL file list - doesn't work if storage id is not 1 Rejected 2016-12-06
Duplicated by TYPO3 Core - Bug #66873: Add a "replace file" button when editing a file Closed 2015-05-10
Duplicated by TYPO3 Core - Feature #67732: Add a "replace file" button when editing a file Closed 2015-06-24

Associated revisions

Revision 01663c47 (diff)
Added by Sven Hartmann over 4 years ago

[!!!][FEATURE] Replace file feature for FAL file list

Provides a new button "replace" at the extended view in FAL equal to
DAM. Its possible to replace a file
  • with a new one -> old file will be overwritten; identifier of the file
    object will be kept
  • with a new one -> old file will be deleted; identifier of the file
    object will be changed to the new filename

The file replacing also respects unique filenames.

To allow editors to replace files the need the "Files: Replace"
permissing needs to be set.

Change-Id: If5882ef620135d4e7238eb8bb56f020304cd1c0c
Resolves: #56133
Releases: master
Reviewed-on: http://review.typo3.org/40797
Reviewed-by: Frans Saris <>
Tested-by: Frans Saris <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Bernhard Eckl over 5 years ago

This is also because if the file is replaced, the references to the file don’t have to be updated manually one by one, they are just right.

#2 Updated by Frans Saris over 5 years ago

  • Status changed from New to Needs Feedback

You can do this already by uploading a new file with the same name and choose "override existing file". Is not that enough?

#3 Updated by Bernhard Eckl over 5 years ago

Yes, but the problem is that the filename on the client is different (e.g. there is a version number in the filename). But the filename on the internet should be clean (good name without versions, person names etc.). If the editors first have to rename the file before uploading, they will make mistakes.

#4 Updated by Alexander Opitz over 5 years ago

  • Category changed from Backend User Interface to File Abstraction Layer (FAL)
  • Status changed from Needs Feedback to New
  • Priority changed from Should have to Could have

#5 Updated by Frank Gerards almost 5 years ago

+1 for this feature , at least inside the media-extension

#6 Updated by Stephan Brun almost 5 years ago

+1 for this feature , at least inside the media-extension, as Frank said

#7 Updated by Sebastian Helzle over 4 years ago

+1 for this feature, would be really helpful in our projects

#8 Updated by Tobias Schmidt over 4 years ago

+1 for this feature

#9 Updated by Tobias Schaefer over 4 years ago

The media-extension is coming with the replace file-feature now (see screenshot). The replace file-button is shown in the edit-view.

#10 Updated by Ephraim Härer over 4 years ago

+1 for this feature, please merge into core

#11 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39629

#12 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39629

#13 Updated by Ephraim Härer over 4 years ago

It's not exactly what I wanted but it looks good and works for me on my 6.2.12 and 6.2.13 installation.

#14 Updated by Bernhard Eckl over 4 years ago

I just tested the patch. It works, but the filename is changed to the new file. The filename should not be changed (this is one reason why I need this feature, filenames should always be the same).

#15 Updated by Markus Klein over 4 years ago

Please add your comments for the patch directly in Gerrit, otherwise they might not be seen by the reviewers!

use the links above and log in with your TYPO3 account. the Reply button on the top allows you to comment and vote (-1 then in your case).

#16 Updated by Ephraim Härer over 4 years ago

This comments you will find also in Gerrit ;-)

#17 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#18 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#19 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#20 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#21 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#22 Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#23 Updated by Gerrit Code Review over 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#24 Updated by Gerrit Code Review over 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#25 Updated by Gerrit Code Review over 4 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40797

#26 Updated by Sven Hartmann over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#27 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF