Bug #63916

Story #82206: list module enhancements/bugfixes

List Module does not show edit links for LiveSearch results

Added by Hannes Lau almost 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-12-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

If a non-admin BE user uses the live search in the top right corner, the search results are displayed without the edit links. This is true even if the user has edit permissions for the records shown.

The reason could be that the search results are displayed on a list view for page uid 0, a page that normal users do not have access to. The permissions calculation for the records is based on this page uid.

Definition of the page uid in TYPO3 CMS 6.2.7
  • sysext/backend/Resources/Public/JavaScript/livesearch.js:20
  • sysext/backend/Resources/Public/JavaScript/livesearch.js:228
Permissions calc
  • sysext/recordlist/Classes/RecordList/DatabaseRecordList.php:1012
  • sysext/recordlist/Classes/RecordList/RecordList.php:253 uses this->pageinfo

This issue did not occur in TYPO3 CMS 4.5 LTS


Files


Related issues

Related to TYPO3 Core - Bug #59900: Backend Search -> Show all respect only permissions from first user groupClosed2014-06-26

Actions
Related to TYPO3 Core - Bug #85251: List Module does not show edit links for LiveSearch resultsClosed2018-06-13

Actions
Has duplicate TYPO3 Core - Bug #81612: No Buttons after Livesearch in list for non admin usersClosed2017-06-19

Actions
Has duplicate TYPO3 Core - Task #86414: No copy and / or cut button in file list searchClosedGianluigi Martino2018-09-28

Actions
#1

Updated by Riccardo De Contardi almost 6 years ago

It seems resolved on 8.0-dev (latest master); could someone confirm? Thank you

#2

Updated by Daniel Windloff about 5 years ago

I could reproduce the bug.
I don't see icons for edit or hide and could not click to the record title to edit the record. The records could be edit in page or list module.
I use the introduction package (advanced editor) and the current master (8.4.0-dev).

#3

Updated by Mona Muzaffar over 4 years ago

  • Related to Bug #81612: No Buttons after Livesearch in list for non admin users added
#4

Updated by Mona Muzaffar over 4 years ago

  • Has duplicate Bug #81612: No Buttons after Livesearch in list for non admin users added
#5

Updated by Mona Muzaffar over 4 years ago

  • Related to deleted (Bug #81612: No Buttons after Livesearch in list for non admin users)
#6

Updated by Riccardo De Contardi about 4 years ago

  • Parent task set to #82206
#7

Updated by Anja Leichsenring almost 4 years ago

  • Status changed from New to Resolved

I can not reproduce the issue with current master and v8.

I close this ticket therefor as resolved. If I am mistaken and there is still an issue, please reopen the ticket and provide a configuration for page tree access, BE user / usergroup config of the failing user and also a step-by-step list what you did to run into the non-edit-icon list. Thanks.

#8

Updated by Stefan P over 3 years ago

  • TYPO3 Version changed from 6.2 to 8

I can reproduce this with latest 8 for any table other than pages. I don't have any special TSconfig. Just admins and non-admins. Buttons in list view from module panel are displayed and working, buttons in list view from search result are not there. Only for table pages the edit buttons are working in both cases, for all others they are not displayed in the search result list view.

#9

Updated by Stefan P over 3 years ago

  • Assignee set to Anja Leichsenring
#10

Updated by Julian Hofmann over 3 years ago

Steps for reproducing it:

  • Fresh TYPO3 installation
  • Install Introduction-Package
  • Create a BE-User having groups "All users" and "Advanced editors"
  • Switch into this BE-User
  • Search for "Out-of-the-box" and click "Show all"
  • In results list you will not see normal edit icons, except within the context-menue
#11

Updated by Hannes Lau about 3 years ago

As there are new steps for reproduction, this issue should not be marked as resolved.

#12

Updated by Christian Kuhn about 3 years ago

  • Related to Bug #85251: List Module does not show edit links for LiveSearch results added
#13

Updated by Josef Glatz about 3 years ago

  • Status changed from Resolved to In Progress
#14

Updated by Josef Glatz about 3 years ago

  • Assignee deleted (Anja Leichsenring)
#15

Updated by Josef Glatz about 3 years ago

Hannes Lau wrote:

As there are new steps for reproduction, this issue should not be marked as resolved.

Thanks Hannes!. Changed the status

#16

Updated by Josef Glatz about 3 years ago

  • TYPO3 Version changed from 8 to 9

Raised TYPO3 version, as the problem exists in master (9) and 8

#17

Updated by Stephan Großberndt about 3 years ago

  • Has duplicate Task #86414: No copy and / or cut button in file list search added
#18

Updated by Gerrit Code Review about 3 years ago

  • Status changed from In Progress to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58426

#19

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58426

#20

Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58426

#21

Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58426

#22

Updated by Gerrit Code Review about 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58426

#23

Updated by Susanne Moog over 2 years ago

  • Status changed from Under Review to Accepted

Review was for a different issue.

#24

Updated by Oliver Bartsch about 1 year ago

  • Status changed from Accepted to Closed

I can't reproduce this anymore. Seems like this got finally fixed with https://forge.typo3.org/issues/85251 and this was just forgotten. I will therefore close it now.

If you feel there is still something that does not work, please let me know and I will re-open the ticket.

Also available in: Atom PDF