Project

General

Profile

Actions

Bug #82461

closed

Story #69617: FormEngine bugs

Backend/TCA: fieldControl->addRecord removes old relations after creating an new entry in the foreign table for the new relation

Added by Dieter Porth almost 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-09-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 8.7.6.: I have a problem with the addRecord-Wizard (fieldControl) in a MN-Relation.

given:
I have defined two relations.

when:
If I press the plus near the selectMulipleSideBySide-Element in the backend, I can create a new record for a new relation.

mistake:
After saving the new record, the new relation to the new record will replace the old two relations.

expected:
After saving the new record, I will see three (= one new + two old) relations.

I testet the option in fieldControl with 'append' and 'prepend' in 'setValue: in TCA
I changed variated multiple to 1

See TCA-example for Relationfield

            'study_programs' => array(
            'exclude' => 1,
            'label' => 'LLL:EXT:... study_programs',
            'config' => array(
                'type' => 'select',
                'renderType' => 'selectMultipleSideBySide',
                'foreign_table' => 'tx_..',
                'MM' => 'tx_...,
...
                'multiple' => 0,
                'fieldControl' => [
                    'editPopup' => [
                        'disabled' => false,
                        'options' => [
                            'title' => 'Edit The selected record!',
                        ],
                    ],
                    'addRecord' => [
                        'disabled' => false,
                        'renderType' => 'addRecord',
                        'options' => [
                            'title' => 'Definiere ',
                            'setValue' => 'append',
                            'pid' => '###CURRENT_PID###',
                        ],
                    ],
                ],
            ),
        ),


Files

typo3-cms_82461.patch (3.15 KB) typo3-cms_82461.patch Dmitry Dulepov, 2018-08-03 12:31

Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Bug #81855: Add new record wizard fails on Save&Close with "select" field and MM settedClosed2017-07-13

Actions
Related to TYPO3 Core - Bug #76863: MM Relation with selectMultipleSideBySide Field - Add wizard resets the MM RelationClosedThomas Hohn2016-06-29

Actions
Related to TYPO3 Core - Bug #84208: TCA: using addRecord in a selectMultipleSideBySide select field overwrites existing dataClosed2018-03-12

Actions
Is duplicate of TYPO3 Core - Bug #82016: Wizards add still not working with MMClosed2017-08-01

Actions
Actions #1

Updated by Christian Heindl almost 7 years ago

I can confirm that issue. Affects also TYPO3 7 LTS.

Actions #2

Updated by Simon Praetorius almost 7 years ago

I can confirm this behavior as well.

Actions #3

Updated by Michael Stopp over 6 years ago

Still a problem in 8.7.8.

Actions #4

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #81855: Add new record wizard fails on Save&Close with "select" field and MM setted added
Actions #5

Updated by Oliver Hader over 6 years ago

  • Description updated (diff)
Actions #6

Updated by Susanne Moog over 6 years ago

  • Category set to FormEngine aka TCEforms
Actions #7

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55826

Actions #8

Updated by Mathias Brodala over 6 years ago

  • Related to Bug #76863: MM Relation with selectMultipleSideBySide Field - Add wizard resets the MM Relation added
Actions #9

Updated by Christian Kuhn over 6 years ago

  • Parent task set to #69617
Actions #10

Updated by Kevin Ditscheid over 6 years ago

  • Is duplicate of Bug #82016: Wizards add still not working with MM added
Actions #11

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55826

Actions #12

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55826

Actions #13

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55826

Actions #14

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55978

Actions #15

Updated by Mathias Brodala over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #16

Updated by Dmitry Dulepov almost 6 years ago

If anybody needs the fix for TYPO3 v7, the patch is attached. University of Basel (Switzerland) sponsored the backport.

Actions #17

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions #18

Updated by Gone With the Wind about 5 years ago

  • Related to Bug #84208: TCA: using addRecord in a selectMultipleSideBySide select field overwrites existing data added
Actions

Also available in: Atom PDF