Bug #93085

Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11

Added by Kim Christiansen 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2020-12-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After I updated to TYPO3 v.10.4.11, the image selection and image cropping is incorrect.

When I selected an image (maxitems=1) and remove it, I cannot select an image again. Add file buttons no longer appear.

In addition, the cropping ratio is no longer correct. The cropping area has changed and the image is rendered with a wrong proportion in the frontend.

I did not have the errors in version 10.4.10.

Maybe a sideffect from https://github.com/TYPO3/TYPO3.CMS/commit/d224f38a9d ?


Files


Related issues

Related to TYPO3 Core - Bug #93086: Distorted images in FE and BE after the update to 10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #93090: Image Cropping broken since TYPO3 10.4.11 releaseClosed2020-12-16

Actions
Related to TYPO3 Core - Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #91855: Image with crop set is JPEG compressed twiceUnder Review2020-07-23

Actions
Related to TYPO3 Core - Bug #93139: Revert image processingClosedBenni Mack2020-07-242020-07-24

Actions
#1

Updated by Peter Neumann 7 months ago

  • Related to Bug #93086: Distorted images in FE and BE after the update to 10.4.11 added
#2

Updated by Tobias Wollender 7 months ago

  • Related to Bug #93090: Image Cropping broken since TYPO3 10.4.11 release added
#3

Updated by Tobias Wollender 7 months ago

  • Related to Bug #93091: Missing "Create new relation"-buttons after deleting the former relation added
#4

Updated by Julian Hofmann 7 months ago

Maybe a sideffect from https://github.com/TYPO3/TYPO3.CMS/commit/5f69b3ac80 ?

Could you please check the commit? Your link is pointing to "[TASK] Set TYPO3 version to 10.4.11-dev"

#5

Updated by Kim Christiansen 7 months ago

  • Description updated (diff)

Sorry my fault. I changed the link to https://github.com/TYPO3/TYPO3.CMS/commit/d224f38a9d

#6

Updated by Simon Gilli 7 months ago

  • Related to Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11 added
#7

Updated by Simon Gilli 7 months ago

  • Related to deleted (Bug #93091: Missing "Create new relation"-buttons after deleting the former relation)
#8

Updated by Markus Klein 7 months ago

  • Related to Bug #91855: Image with crop set is JPEG compressed twice added
#9

Updated by Markus Klein 7 months ago

  • Status changed from New to Closed

Resolved with #93139

#10

Updated by Markus Klein 7 months ago

  • Related to Bug #93139: Revert image processing added

Also available in: Atom PDF