Bug #91855

Image with crop set is JPEG compressed twice

Added by Christian Toffolo 11 months ago. Updated 5 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
Image Generation / GIFBUILDER
Target version:
-
Start date:
2020-07-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Image with crop set is JPEG compressed twice so it loses quality 2 times based on jpg_quality setting.

1st compress when crop is executed: https://github.com/TYPO3/TYPO3.CMS/blob/5275e76e4ae7e00a0bce59b8d458e547e427b92b/typo3/sysext/core/Classes/Resource/Processing/LocalCropScaleMaskHelper.php#L87
2nd compress when scaling is executed:
https://github.com/TYPO3/TYPO3.CMS/blob/5275e76e4ae7e00a0bce59b8d458e547e427b92b/typo3/sysext/core/Classes/Resource/Processing/LocalCropScaleMaskHelper.php#L118

A solution could be to use a $jpegQuality=100 the first time it's compressed if it will be compressed a second time (using the configured jpg_quality).


Files

5y1nX.png (248 KB) 5y1nX.png Oleg Karun, 2021-01-12 10:10

Related issues

Related to TYPO3 Core - Bug #81796: LocalCropScaleMaskHelper does not respect quality settingClosed2017-07-05

Actions
Related to TYPO3 Core - Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #93090: Image Cropping broken since TYPO3 10.4.11 releaseClosed2020-12-16

Actions
Related to TYPO3 Core - Bug #93086: Distorted images in FE and BE after the update to 10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11Closed2020-12-16

Actions
Precedes TYPO3 Core - Bug #93139: Revert image processingClosedBenni Mack2020-07-242020-07-24

Actions
#1

Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65088

#2

Updated by Gerrit Code Review 11 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65088

#3

Updated by Gerrit Code Review 11 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65088

#4

Updated by Gerrit Code Review 11 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65088

#5

Updated by Helmut Hummel 11 months ago

  • Related to Bug #81796: LocalCropScaleMaskHelper does not respect quality setting added
#6

Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#7

Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#8

Updated by Gerrit Code Review 11 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#9

Updated by Gerrit Code Review 11 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#10

Updated by Gerrit Code Review 11 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#11

Updated by Gerrit Code Review 11 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#12

Updated by Gerrit Code Review 11 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#13

Updated by Gerrit Code Review 10 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#14

Updated by Gerrit Code Review 10 months ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#15

Updated by Gerrit Code Review 10 months ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#16

Updated by Gerrit Code Review 10 months ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#17

Updated by Gerrit Code Review 9 months ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65187

#18

Updated by Gerrit Code Review 7 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66672

#19

Updated by Helmut Hummel 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#20

Updated by Markus Klein 6 months ago

  • Related to Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11 added
#21

Updated by Markus Klein 6 months ago

  • Related to Bug #93090: Image Cropping broken since TYPO3 10.4.11 release added
#22

Updated by Markus Klein 6 months ago

  • Related to Bug #93086: Distorted images in FE and BE after the update to 10.4.11 added
#23

Updated by Markus Klein 6 months ago

  • Related to Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11 added
#24

Updated by Benni Mack 6 months ago

  • Precedes Bug #93139: Revert image processing added
#25

Updated by Markus Klein 6 months ago

  • Status changed from Resolved to Accepted
  • % Done changed from 100 to 0

Reopened so patch can be repushed.

#26

Updated by Gerrit Code Review 6 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67234

#27

Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67234

#28

Updated by Oleg Karun 5 months ago

Also available in: Atom PDF