Project

General

Profile

Actions

Bug #93090

closed

Image Cropping broken since TYPO3 10.4.11 release

Added by Florian Langer over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Image Cropping
Target version:
-
Start date:
2020-12-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Greetings!

I've noticed that the image cropping does not work properly anymore after the 10.4.11 release.
All cropped images get stretched out after saving the cropped image in the backend and clear all previous processed images (see screenshots).

Steps to reproduce:
  • Crop an image
  • Save the CE
  • Close CE
  • Reopen CE

--> Image is now stretched out (like in the screenshot)

Steps to reproduce in frontend:
  • Clear temp assets
  • Clear cache
  • Go to Frontend

--> Image is now stretched out (like in the screenshot)

Thanks in advance!


Files

cropping_broken_before.jpg (122 KB) cropping_broken_before.jpg Florian Langer, 2020-12-16 14:58
copping_broken_after_release.jpg (99.3 KB) copping_broken_after_release.jpg Florian Langer, 2020-12-16 14:58
cropping_broken_frontend.jpg (192 KB) cropping_broken_frontend.jpg Florian Langer, 2020-12-16 14:58
cropping_broken_original_image.jpg (215 KB) cropping_broken_original_image.jpg Florian Langer, 2020-12-16 14:58

Related issues 6 (0 open6 closed)

Related to TYPO3 Core - Bug #93086: Distorted images in FE and BE after the update to 10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11Closed2020-12-16

Actions
Related to TYPO3 Core - Bug #91855: Image with crop set is JPEG compressed twiceClosed2020-07-23

Actions
Related to TYPO3 Core - Bug #93139: Revert image processingClosedBenni Mack2020-07-242020-07-24

Actions
Related to TYPO3 Core - Bug #95760: Still Problem with CropClosed2021-10-24

Actions
Actions #1

Updated by Josef Glatz over 3 years ago

  • Priority changed from Should have to Must have

I can confirm the behaviour

Actions #2

Updated by Tobias Wollender over 3 years ago

  • Related to Bug #93086: Distorted images in FE and BE after the update to 10.4.11 added
Actions #3

Updated by Tobias Wollender over 3 years ago

  • Related to Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11 added
Actions #4

Updated by Simon Gilli over 3 years ago

  • Related to Bug #93092: Weird visualization of thumbnails in CE after upgrading to 10.4.11 added
Actions #5

Updated by Markus Klein over 3 years ago

  • Related to Bug #91855: Image with crop set is JPEG compressed twice added
Actions #6

Updated by Markus Klein over 3 years ago

I can't reproduce the Frontend behaviour, only backend behaviour

Actions #7

Updated by Ulrich Koch over 3 years ago

I can confirm the behaviour – Frontend and Backend

Actions #8

Updated by Thomas Maroschik over 3 years ago

I can reproduce that too. I already debugged the issue in depth and will soon push a patchset.

Actions #9

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67173

Actions #10

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67173

Actions #11

Updated by Helmut Hummel over 3 years ago

Can somebody here please provide exact data to reproduce? An image and the exact sys_file_reference DB crop field json? thanks!

Actions #12

Updated by Helmut Hummel over 3 years ago

Helmut Hummel wrote in #note-11:

Can somebody here please provide exact data to reproduce? An image and the exact sys_file_reference DB crop field json? thanks!

Never mind. Can reproduce this as well.

Actions #13

Updated by Jörn Wagner over 3 years ago

I can confirm the bug and also the fix referenced in #93090#note-10. I have included it already in one live installation via composer patch because editors started to be affected. It would be most welcome if this could be released in 10.4.12 asap.

Actions #14

Updated by Andrea Moroni over 3 years ago

I can confirm the bug. But the fix doesn't work in data-variant="default" and Bootstrap Package Master...here arrives the original size in FE, even if the cropping is shown correct in BE.

Actions #15

Updated by Ulrich Koch over 3 years ago

Only the backend works on my live server (GraphicsMagick), as with Andrea Morini (Ciao!), the original image is rendered in the frontend. I don't use Bootstrap-Package.
In my development environment (Mamp: ImageMagick), however, the backend and frontend work correctly.

Actions #16

Updated by Markus Klein over 3 years ago

  • Related to Bug #93139: Revert image processing added
Actions #17

Updated by Markus Klein over 3 years ago

  • Status changed from Under Review to Closed

Resolved with #93139

Actions #18

Updated by Georg Ringer over 2 years ago

  • Related to Bug #95760: Still Problem with Crop added
Actions

Also available in: Atom PDF