Project

General

Profile

Actions

Bug #93706

closed

Content element "View" button does not reload page

Added by Christian Weiske over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2021-03-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When editing a content element, clicking on the "view" button opens a new tab with the anchor of the element: http://example.org/foo/#c2342

When changing, then saving element and clicking "View" again, the page does not reload.

When changing the element and clicking "View" without saving, a popup asks if I want to save. I confirm, and the page does not reload.


This happens in TYPO3 v10.4.13 and also 9.5.24.
The relevant code seems to be in typo3/sysext/backend/Resources/Public/JavaScript/FormEngine.js, FormEngine.previewAction and previewActionCallback.

There has been a similar bug years ago: #82456.


Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Bug #82456: Multiple usage of "save and preview" button does not reload preview tabClosedFrank Nägler2017-09-11

Actions
Related to TYPO3 Core - Bug #95207: view button in editing mode of a fluid_styled_content element did not show new changesClosed2021-09-13

Actions
Related to TYPO3 Core - Bug #99286: Preview javascript broken in multidomain projects (regression)Resolved2022-12-06

Actions
Related to TYPO3 Core - Bug #100795: Content element "View" button does not reload page, when preview is hosted on different (sub-)domainClosed2023-05-03

Actions
Actions #1

Updated by Christian Weiske over 3 years ago

  • Related to Bug #82456: Multiple usage of "save and preview" button does not reload preview tab added
Actions #2

Updated by Patrick Gaumond about 3 years ago

  • Category changed from FormEngine aka TCEforms to Miscellaneous
  • Is Regression set to Yes

I just want to confirm that this behaviour is still present in 10.4.14

The View button in a tt_content open a new tab after saving and show ok but if we go back in BE and change again the tt_content, click View then "Save changes and view", it will go to the tab without reloading.

Actions #3

Updated by Jessica Jagodzinski over 2 years ago

  • TYPO3 Version changed from 10 to 11
Actions #4

Updated by Jessica Jagodzinski over 2 years ago

  • TYPO3 Version changed from 11 to 10
Actions #5

Updated by Jessica Jagodzinski over 2 years ago

I can confirm this behavior for version TYPO3 11.5.5 as well.

Actions #6

Updated by Björn Jacob almost 2 years ago

  • Status changed from New to In Progress
Actions #7

Updated by J. Peter M. Schuler almost 2 years ago

FWIW: I can’t reproduce that with a custom record. That missing/broken behavior seems to be bound to tt_content (and perhaps pages?) only. Both tables have a lot of custom code for the view action (e.g. the additional eye-button in list view).

Actions #8

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #9

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #10

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #11

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #12

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #13

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #14

Updated by Annett Jähnichen almost 2 years ago

  • Related to Bug #95207: view button in editing mode of a fluid_styled_content element did not show new changes added
Actions #15

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #16

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #17

Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #18

Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #19

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #20

Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #21

Updated by Gerrit Code Review almost 2 years ago

Patch set 9 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #22

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #23

Updated by Gerrit Code Review almost 2 years ago

Patch set 10 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #24

Updated by Gerrit Code Review almost 2 years ago

Patch set 11 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75164

Actions #25

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #26

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #27

Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/75492

Actions #28

Updated by Tobias Jungmann almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #29

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions #30

Updated by Georg Ringer over 1 year ago

  • Related to Bug #99286: Preview javascript broken in multidomain projects (regression) added
Actions #31

Updated by Oliver Hader about 1 year ago

  • Related to Bug #100795: Content element "View" button does not reload page, when preview is hosted on different (sub-)domain added
Actions

Also available in: Atom PDF