Project

General

Profile

Actions

Bug #100847

closed

Epic #99669: CKEditor5 Collection

Story #101906: CKEditor5 missing plugins

Add the missing Font Plugin to CKEditor build

Added by Chris topher about 1 year ago. Updated 10 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Start date:
2023-05-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In CKEditor 4 it was possible to adjust font-family, font-size and font-color using the functions, which were present in CKEditor.

With TYPO3 12 this is no longer possible. font-family, font-size and font-color can no longer be changed. Reason for this shortcoming is, that the Font Plugin, which provides that functionality for CKEditor 5, is not part of the bundle coming with TYPO3 12.

Please add this plugin again to the CKEditor build by using

npm i --save \
        @ckeditor/ckeditor5-font@^37.1.0

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #100852: Add list properties feature to CKEditorClosed2023-05-10

Actions
Related to TYPO3 Core - Task #103311: Add documentation for font plugin to CKEditor5ClosedChris Müller2024-03-06

Actions
Actions #1

Updated by Cyrill Gsell about 1 year ago

I have a related issue, I would like to use the TableCaption plugin which seems to be missing in the CKEditor build used by the core.

Actions #2

Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #3

Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79008

Actions #4

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #5

Updated by Christian Hackl about 1 year ago

yes a decent solution for the problem with missing "node" modules/plugins is really missing!

Due to these current limitations of the RTE we are currently not updating TYPO3...

Actions #6

Updated by Johannes Nielsen about 1 year ago

  • Related to Feature #100852: Add list properties feature to CKEditor added
Actions #7

Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #8

Updated by Oliver Hader about 1 year ago

  • Parent task set to #100784
Actions #9

Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #10

Updated by Benni Mack about 1 year ago

  • Target version changed from 12 LTS to Candidate for patchlevel
Actions #11

Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #12

Updated by Gerrit Code Review about 1 year ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #13

Updated by Georg Tiefenbrunn about 1 year ago

As @Cyrill Gsell additional request made it's into this change please also consider adding @ckeditor/ckeditor5-language (#101128).
The text part language feature implements the WCAG 3.1.2 Language of Parts specification.

Actions #14

Updated by Kai Ole Hartwig about 1 year ago

We have noticed in our project that more CKEditor 5 plugins are missing to create the same functionality as before, from our point of view the following plugins would be useful:

Autoformat,
AutoLink,
CloudServices,
Code,
CodeBlock,
Highlight,
IndentBlock,
ListProperties,
PageBreak,
SpecialCharacters,
SpecialCharactersArrows,
SpecialCharactersCurrency,
SpecialCharactersEssentials,
SpecialCharactersLatin,
SpecialCharactersMathematical,
SpecialCharactersText,
TableColumnResize,
TextPartLanguage,

Actions #15

Updated by Stefan Berger 11 months ago

Also, the ShowBlocks plugin is missing from the ckeditor5 bundle: https://ckeditor.com/docs/ckeditor5/latest/features/show-blocks.html
It was released in CKeditor version v38.1.0, which is currently used in the core and can therefore be easily added: https://github.com/ckeditor/ckeditor5/releases/tag/v38.1.0
This plugin was already available in the CKEditor 4 version and was effectively removed with TYPO3 12.
Please add it to the list of builtinPlugins, because it helps a lot to avoid editors creating freaky content.

Actions #16

Updated by Cyrill Gsell 11 months ago

I saw you added various plugins to the CKEditor including the TableCaption, thank you for the effort!
Do you know yet in what maintenance release these changes will be published?

Actions #17

Updated by Benjamin Franzke 10 months ago

  • Parent task changed from #100784 to #101906
Actions #18

Updated by Gerrit Code Review 10 months ago

Patch set 7 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #19

Updated by Gerrit Code Review 10 months ago

Patch set 8 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #20

Updated by Gerrit Code Review 10 months ago

Patch set 9 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #21

Updated by Gerrit Code Review 10 months ago

Patch set 10 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #22

Updated by Gerrit Code Review 10 months ago

Patch set 11 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #23

Updated by Gerrit Code Review 10 months ago

Patch set 12 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #24

Updated by Gerrit Code Review 10 months ago

Patch set 13 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #25

Updated by Gerrit Code Review 10 months ago

Patch set 14 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #26

Updated by Gerrit Code Review 10 months ago

Patch set 15 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #27

Updated by Gerrit Code Review 10 months ago

Patch set 16 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #28

Updated by Gerrit Code Review 10 months ago

Patch set 17 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #29

Updated by Gerrit Code Review 10 months ago

Patch set 18 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #30

Updated by Gerrit Code Review 10 months ago

Patch set 19 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #31

Updated by Gerrit Code Review 10 months ago

Patch set 20 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #32

Updated by Gerrit Code Review 10 months ago

Patch set 21 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #33

Updated by Gerrit Code Review 9 months ago

Patch set 22 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #34

Updated by Gerrit Code Review 9 months ago

Patch set 23 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #35

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81397

Actions #36

Updated by Christian Ludwig 9 months ago

Why aren't all plugins available as there where in TYPO3 v11? It would be acceptable to remove some from the presets but removing the plugins completely is a breaking change and causes delays in updating to v12.

We are missing the FontColor (https://ckeditor.com/docs/ckeditor5/latest/api/module_font_fontcolor-FontColor.html) and ColorUI (https://ckeditor.com/docs/ckeditor5/latest/api/module_font_ui_colorui-ColorUI.html) plugin.

Actions #37

Updated by Edward Riller 8 months ago

Typo3 12.4.8 with rte_ckeditor .

In /typo3/sysext/rte_ckeditor/Configuration/RTE/ Full.yaml following setting don't have an effect in the editor in the BE:

    toolbar:
      items:
        - clipboard
        - indent
        - outdent

- clipboard (button doesn't show up)
- indent (button greyed out)
- outdent (button greyed out)

Following settings of format doesn't work either:

editor:
  config:
    style:
      definitions:
        # block level styles
        - { name: 'Orange title H2', element: 'h2', classes: [], styles: { color: 'orange', background: 'blue' } }
        - { name: 'Orange title H3', element: 'h3', classes: [], styles: { color: 'orange', background: 'blue' } }
        - { name: 'Quote / Citation', element: 'blockquote', classes: [],  }
        - { name: 'Code block', element: 'code', classes: [],  }
        # Inline styles
        - { name: 'Yellow marker', element: 'span', classes: [], styles: { background-color: 'yellow' } }

The editor in BE, though it has a (trunkated) drop-down menue "Styles" , there is none of effect on the text in the editor window.

Plugins are dearly missed, especially the toolbar items:

        - fontFamily
        - fontSize
        - '|'
        - fontColor
        - fontBackgroundColor

The tutorial Timestamp-Plugin (https://docs.typo3.org/c/typo3/cms-rte-ckeditor/12.4/en-us/Configuration/Examples.html ) unfortunately also doesn't work, as no "Timestamp" button shows up in the BE in the editor.

Hope this is of interest for you. Kind regards.

Actions #38

Updated by Gerrit Code Review 7 months ago

Patch set 24 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #39

Updated by Gerrit Code Review 7 months ago

Patch set 25 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #40

Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81397

Actions #41

Updated by Gerrit Code Review 5 months ago

Patch set 26 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #42

Updated by Martin Weymayer 5 months ago

TextPartLanguage and Abbreviation plugin is really missing - TTYPO3 has always been known for creating accessible websites... without these plugins it is not possible. Would be urgently needed!

Actions #43

Updated by Gerrit Code Review 5 months ago

Patch set 27 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #44

Updated by Gerrit Code Review 5 months ago

Patch set 28 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79006

Actions #45

Updated by Gerrit Code Review 5 months ago

Patch set 3 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81397

Actions #46

Updated by Anonymous 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #47

Updated by Chris Müller 4 months ago

  • Related to Task #103311: Add documentation for font plugin to CKEditor5 added
Actions #48

Updated by Benni Mack 10 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF