Bug #14858

extended clipboard: setCopyMode can`t be set to copy by default

Added by Sacha Vorbeck about 14 years ago. Updated 12 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2005-07-11
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
clipboard default move copy
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hi,

I couldn`t find any TCAdefaults or other TSconfig option to switch the copy mode of the extended clipboard to copy by default.

At the moment the default is "move" which can be very annoying.

Please add the possibility to choose the default behaviour of the "setCopyMode" button.

Thanks,
Sacha

(issue imported from #M1277)


Related issues

Duplicated by TYPO3 Core - Feature #70759: Changing the default clipboard option from "move elements" to "copy elements" Closed 2015-10-15

History

#1 Updated by Sebastian Kurfuerst almost 14 years ago

This issue is more complicated than it seems, because there setting for "move" is empty - and there is no easy condition to find out whether the default should apply or not. I will have a deeper look into it.
Greets, Sebastian

#2 Updated by Sebastian Kurfuerst almost 14 years ago

this issue is not so easy to fix and I don't see a nice solution at the moment. A patch is welcome, but currently I cannot have a deeper look into it.
Greets, Sebastian

#3 Updated by Oliver Hader almost 8 years ago

  • Category set to Backend User Interface
  • Target version changed from 0 to 4.7.0
  • TYPO3 Version changed from 3.8.0 to 4.6
  • PHP Version changed from 4 to 5.3

Should be a UserTS configuration and maybe an additional setting in the user preferences.

#4 Updated by Steffen Ritter over 7 years ago

  • Target version deleted (4.7.0)

#5 Updated by Gabriel Kaufmann / Typoworx NewMedia over 6 years ago

Is there anything new for the TYPO3 4.6 oder 4.7 Tree?

#6 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.4 (Backend)

#7 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38419

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38419

#9 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38419

#10 Updated by Wouter Wolters over 4 years ago

  • Status changed from Under Review to New

#11 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#12 Updated by Benni Mack almost 4 years ago

  • Target version deleted (7.5)

#13 Updated by Tilo Baller almost 4 years ago

What was the reason for abandoning the patch in review and what is the current progress of this feature?

I got several requests from customers for adjusting the default behaviour to 'copy' instead of 'move'.

#14 Updated by Daxboeck no-lastname-given about 1 year ago

  • Tracker changed from Feature to Bug
  • Target version set to 8.7.19
  • TYPO3 Version set to 8
  • PHP Version changed from 5.3 to 7.2
  • Tags set to clipboard default move copy
  • Complexity set to medium

I did now ask my developers to create a patch as the default of "move" when someone selects the 2nd or 3rd clipboard is very annoying.
It is against a thought of safety, it is against common sense.
I just had too many cases where by accident stuff has been moved instead of copied.
"copy" must be the default, there should be no doubt about it.

#15 Updated by Susanne Moog 12 months ago

  • Target version changed from 8.7.19 to Candidate for patchlevel

Also available in: Atom PDF