Feature #18968

Add existing records to IRRE field

Added by Jonas Felix over 11 years ago. Updated about 4 years ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2008-06-17
Due date:
% Done:

0%

PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

Currently it's only possible to create a completely new record within a IRRE field.

If you wan't to use IRRE for existing tables, exisiting extensions and existing records it should be possible to add existing records to a IRRE field.

Just the button is missing with the folder icon which leads to a popup ;-)
(issue imported from #M8731)


Related issues

Related to TYPO3 Core - Feature #16400: Adding existing records Closed 2007-07-27
Related to TYPO3 Core - Bug #23375: IRRE: fails to save preexisting child record selected by combo New 2010-08-15
Duplicated by TYPO3 Core - Bug #23507: IRRE: Connecting data is only possible with new data Closed 2010-09-05

History

#1 Updated by Oliver Hader over 11 years ago

I don't exactly understand how the result should look like - but I guess it's not a bug, but a new feature. Maybe you could come up with a more detailed example or graphical mockup. Thanks in advance!

#2 Updated by Jonas Felix over 11 years ago

Imagine you have a IRRE field, and you wan't to add an existing record which has to relate to your current record.

I just don't understand why there is just an add button and not also a 'select existing record' folder icon...

IRRE is a great improvement for TYPO3 and I would like to use it in more extensions, but this is something I would need for a lot of relations.

Imagine you have a training and you wan to add tt_address records (with a clean separate mm table) to this training. But you wan't to use the cool IRRE interface. But you have the tt_address record and you wan't to edit the tt_address record like other IRRE records.

I think the IRRE interface could be used for much more relations as it is now. It should be possible to change nearly every relation to a IRRE field.

Imagine tt_news -> you could directly edit the selected tt_news category within the news.

Or imagine comments, you could edit the comments directly within the news element, or shop product or wherever you have comments.

I would like to do this improvement, but I just don't know where to start. It should be discussed, because it extends the IRRE concept. And I think that's a little bit why you don't understand me. I wanna use IRRE for something which IRRE is not maid for, but it has the capabilities and needs just some small improvements.

Another example. Imagine you have a typical Hotel/Offer example (like in you example data) and now you wan't to move the offer to another hotel by selecting it in the IRRE field of the other hotel.

#3 Updated by Sonja Schubert over 11 years ago

That would be realy cool. This way you could use the IRRE feature for a lot more relations than it is used now.

You could in example list all be_groups within the be_user within a IRRE field, so you could click right on the group and edit it.

Even better you could directly list all users which belong to a be_group within the group record.

#4 Updated by Fabien Udriot over 9 years ago

Any news about this issue? I am facing the same problem. On one hand, I have a person (addresses), on the other hand I have a fe_user that I would like to link.

Is there some configuration to add in order to be able to select an existing fe_user within addresses.

Here is the TCA:

'fe_user' => Array (
'label' => '...'
'config' => Array (
'type' => 'inline',
'foreign_table' => 'fe_users',
'foreign_field' => 'person',
'foreign_label' => 'username',
'maxitems' => 1,
)
),

Cheers,

#5 Updated by Thomas Deinhamer over 9 years ago

Ehm, not sure what you need exactly, but maybe haveing a look here will help you:
http://typo3.org/documentation/document-library/core-documentation/doc_core_api/4.3.0/view/4/2/#id2529282

Notice the option "foreign_selector", it will render a list of all available records, so you can choose from.

#6 Updated by Daniel BrĂ¼n about 9 years ago

I think there still is no decent way to do this. I'll try to further explain the problem:

There are two tables: Cars and Engines. Usually there a couple of engines that are used in many cars. Every car can have only one engine, an engine can be part of many different cars. It would make sense to put the ID of an engine into the cars-table.

When creating a new car in the database it is easy to display a list of existing engines in a select-box, simply by setting type=select for the appropriate field in the cars table.

Problem: Whenever the user tries to input a brand new car with a brand new engine he can not do it in a single form, because he can only select an existing engine and not create a new one on the spot.

It looks like this feature is only available when using a MM-relation between cars and engines ... which makes no sense at all.

#7 Updated by Thomas Deinhamer about 9 years ago

I guess you're refering to some kind of IRRE for a single record only.
Actually that's what I'd like to have also - an interface like IRRE, but for
defining a single relation only.

But you can use the "add" wizard to create new records "on the fly".
See here: http://typo3.org/documentation/document-library/core-documentation/doc_core_api/4.3.0/view/4/2/#id2524566

Not perfect, but working. The same is used for creating filemounts in TYPO3.

#8 Updated by Thomas Deinhamer over 8 years ago

  • Target version deleted (0)

It's like a group/db field, with the possibility to edit the related record inline. Like group/irre. :D

#9 Updated by Robert Wildling almost 7 years ago

Is there any progress on this topic? It would really be an important feature! Thanks!

#10 Updated by Urs Braem about 5 years ago

I think this can be closed, as the feature seems to have been implemented for a while, see e.g. https://forge.typo3.org/issues/43239

#11 Updated by Mathias Schreiber almost 5 years ago

  • Description updated (diff)
  • Status changed from New to Closed

#12 Updated by Philipp Kitzberger almost 5 years ago

  • Status changed from Closed to New

The patch in issue #43239 has been reverted shortly after it's been implemented. So this issue here is still a feature to be implemented.

#13 Updated by Riccardo De Contardi about 4 years ago

  • Category set to 978

#14 Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #23375: IRRE: fails to save preexisting child record selected by combo added

Also available in: Atom PDF