Project

General

Profile

Actions

Bug #24087

closed

Content "All languages" disappears in Page module

Added by Stefano Cecere over 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-11-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

if you set a content element to [All] languages, it disappears from the Page view of the page. (you can see it again only with List module)

(issue imported from #M16427)


Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Bug #42771: Languages view (Web->Page) is unusable with multilanguage content elements since 4.7.5Closed2012-11-07

Actions
Related to TYPO3 Core - Bug #42768: multilanguage content elements (language "all") not shown anymore if defLangBinding is usedClosed2012-11-07

Actions
Has duplicate TYPO3 Core - Bug #35177: Page module: CE for "All languages" are not shownClosed2012-03-23

Actions
Has duplicate TYPO3 Core - Bug #41429: setting language = all removes contentClosed2012-09-27

Actions
Actions #1

Updated by Ralf-Rene Schroeder almost 13 years ago

it is also the same in TYPO3 4.5.1
(and i remember that i have the same Problem in june 2010 - and this was version 4.4.x

with TV all works perfect, but with standard templating not

Actions #2

Updated by Tolleiv Nietsch almost 13 years ago

heh confirmed, doesn't happen in TV, sorry for my first comment ;)

Actions #3

Updated by Markus Klein almost 12 years ago

Still valid up to 4.7

Actions #4

Updated by Gerrit Code Review almost 12 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9840

Actions #5

Updated by Georg Ringer almost 12 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Heiko Kromm over 11 years ago

Is this fixed in 4.7.1?
I can produce this bug in fresh 4.7.1 installation.

Actions #7

Updated by Georg Ringer over 11 years ago

  • Target version deleted (0)

no just pushed to master, sorry

Actions #8

Updated by Gerrit Code Review over 11 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/12078

Actions #9

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/12079

Actions #10

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12080

Actions #11

Updated by Heiko Kromm over 11 years ago

I think the path does not solve the problem completly.
Content elements set to [ALL] languages are only shown in default language, but they are not shown if I switch in columns view to a different language. Even in side-by-side languages view the content element is only shown in default language.

Actions #12

Updated by Gerrit Code Review over 11 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/12079

Actions #13

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12185

Actions #14

Updated by Heiko Kromm over 11 years ago

Patch works for me.
Thanks

Actions #15

Updated by Gerrit Code Review over 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12185

Actions #16

Updated by Gerrit Code Review over 11 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12185

Actions #17

Updated by Gerrit Code Review over 11 years ago

Patch set 3 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/12079

Actions #18

Updated by Georg Ringer over 11 years ago

  • Status changed from Under Review to Resolved
Actions #19

Updated by Heiko Kromm over 11 years ago

It's not resolved in 4.7.4!
Has the patch ever been published? This is essential for multilanguage sites.

Actions #21

Updated by Gerrit Code Review over 11 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12080

Actions #22

Updated by Georg Ringer over 11 years ago

  • Status changed from Under Review to Resolved
Actions #23

Updated by Gerrit Code Review over 11 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15613

Actions #24

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/15614

Actions #25

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/15615

Actions #26

Updated by Marcus Schwemer over 11 years ago

  • Status changed from Under Review to Resolved
Actions #27

Updated by M. Stichweh over 11 years ago

Still not working in 4.7.5!
It works in columns view but not in languages view. It was working in languages view in 4.7.3 but now the CE completly disappears (language binding is activated).
It seems to work if "&& $row['sys_language_uid'] != -1" is removed on line 410 in "/typo3/sysext/cms/layout/class.tx_cms_layout.php".

Actions #28

Updated by Stefan Galinski over 11 years ago

The merged changes are causing critical bugs. See the related issues for more information. IMHO this patch series should be completely reverted for now.

Actions #29

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF