Bug #83721

Page translated using localization overview is shown as normal page L=0

Added by Tymoteusz Motylewski over 2 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Start date:
2018-01-29
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In v9 when you translate a page using localization overview from the Info module
The page is create as a subpage of a given page instead of it's translation.

Translating a page uid =10, pid=5 results in page uid=11, pid=10, sys_language_uid= 0


Related issues

Related to TYPO3 Core - Bug #86181: Translation in the localisation overview creates pages instead of translations. Closed 2018-09-07
Related to TYPO3 Core - Bug #89436: module WEB > list: localize a page does not work correctly Closed 2019-10-17
Duplicated by TYPO3 Core - Bug #87490: New translations created using Info module are considered new pages Closed 2019-01-18

Associated revisions

Revision 18ed013f (diff)
Added by Susanne Moog 5 months ago

[BUGFIX] Use DataHandler localize in Localization Overview

Instead of opening a multi-form-engine form when creating new
translations via translation overview the datahandler is called
upon to localize the pages.

This has the advantage that it
- works
- consistently as in page module
- keeps all types (page type changed in earlier versions)

Resolves: #83721
Resolves: #83720
Releases: master, 9.5
Change-Id: I39ec0f63dce5ddcd8d3f34c849367dc2c621f8bd
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62874
Tested-by: TYPO3com <>
Tested-by: Tobi Kretschmann <>
Tested-by: Daniel Goerz <>
Reviewed-by: Tobi Kretschmann <>
Reviewed-by: Daniel Goerz <>

Revision f6bc1240 (diff)
Added by Susanne Moog 5 months ago

[BUGFIX] Use DataHandler localize in Localization Overview

Instead of opening a multi-form-engine form when creating new
translations via translation overview the datahandler is called
upon to localize the pages.

This has the advantage that it
- works
- consistently as in page module
- keeps all types (page type changed in earlier versions)

Resolves: #83721
Resolves: #83720
Releases: master, 9.5
Change-Id: I39ec0f63dce5ddcd8d3f34c849367dc2c621f8bd
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62882
Tested-by: TYPO3com <>
Tested-by: Daniel Goerz <>
Reviewed-by: Daniel Goerz <>

History

#1 Updated by Tymoteusz Motylewski over 2 years ago

  • Description updated (diff)

#2 Updated by Riccardo De Contardi about 2 years ago

  • Category set to Backend User Interface

Still present on 9.2.0-dev

#3 Updated by Susanne Moog over 1 year ago

  • Target version set to 9 LTS

#4 Updated by Susanne Moog over 1 year ago

  • Target version changed from 9 LTS to Candidate for patchlevel

#5 Updated by Christian Kuhn over 1 year ago

  • Related to Bug #86181: Translation in the localisation overview creates pages instead of translations. added

#6 Updated by Georg Ringer over 1 year ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version changed from Candidate for patchlevel to 9 LTS

#7 Updated by Georg Ringer over 1 year ago

better description in duplicate

Prerequisite: A system with two (probably more) languages.

Create a few pages in the default language.
Open the localisation overview in the info module.
Select some (or all) pages in the column of the second language (checkboxes).
Click on "Create new translation headers"-button at the top.
Enter the translated titles. (Somewhat difficult because you can't see the original title. This may be the first indicator of the problem).
Save
See that subpages have been created for the pages, but no translations.
Used TYPO3 Version is: 9.4

#8 Updated by Benni Mack over 1 year ago

  • Target version changed from 9 LTS to Candidate for patchlevel

This is a very nasty issue. This is related to the fact that we do this ugly "just localized" functionality (calling DataHandler and then redirecting to FormEngine via returnURL) which is broken now because we don't do pages_language_overlay now.

In the context of the Info => Localization Overview, we have to tackle that different - basically reworking the whole module IMHO.

possibility a) Rework module
- It is not possible to translate multiple records at once anymore but we introduce a button "Translate" for each langauge in each page.

possibility b) - rework "Just Localized" functionality
- We built a new pattern where edit document controller shows a new record translation before saving it - this has a bigger impact

#9 Updated by Georg Ringer over 1 year ago

  • Duplicated by Bug #87490: New translations created using Info module are considered new pages added

#10 Updated by Andreas Kiessling about 1 year ago

Still present in 9.5.7

#11 Updated by Riccardo De Contardi 10 months ago

Still present on 10.0.1.0

#12 Updated by Riccardo De Contardi 8 months ago

  • Related to Bug #89436: module WEB > list: localize a page does not work correctly added

#13 Updated by Gerrit Code Review 5 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62874

#14 Updated by Susanne Moog 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Gerrit Code Review 5 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62882

#16 Updated by Susanne Moog 5 months ago

  • Status changed from Under Review to Resolved

#17 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF