Bug #90617

Epic #90812: Fluid-based Page Module

Page Module: No content elements displayed with mod.web_layout.defLangBinding

Added by Susanne Moog 8 months ago. Updated 18 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2020-03-02
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In current v10 with mod.web_layout.defLangBinding = 1 no content is displayed in the old Page Module at all.

noContent.png View - Old Page Module (143 KB) Susanne Moog, 2020-03-15 12:28

shouldBeAligned.png View - New Page Module (221 KB) Susanne Moog, 2020-03-15 12:28

withoutAlign.png View - defLangBinding = 0 - expected result (658 KB) Susanne Moog, 2020-03-15 12:38

withAlign.png View - defLangBinding = 1 - expected result (557 KB) Susanne Moog, 2020-03-15 12:38


Related issues

Related to TYPO3 Core - Task #90348: PageLayoutView and BackendLayout should be refactored to separate rendering, processing and fetching of content Closed 2020-02-10
Related to TYPO3 Core - Bug #90866: Fluid based page module not showing elements with language=All ([sys_language_uid]=-1) Rejected 2020-03-28
Related to TYPO3 Core - Task #90315: Split up PageLayoutView code into smaller chunks Closed 2020-02-04
Related to TYPO3 Core - Bug #92482: Fluid based page module is missing defaultLanguageBinding functionality Accepted 2020-10-05
Duplicated by TYPO3 Core - Bug #92360: with mod.web_layout.defLangBinding set to true, no content output is generated Closed 2020-09-21
Blocks TYPO3 Core - Bug #92454: Invalid colPos/language UID used in "Languages" view with defLangBinding Under Review 2020-09-30

Associated revisions

Revision 04fe3a7c (diff)
Added by Oliver Bartsch 18 days ago

[BUGFIX] Pass defLangBinding to generateLanguageView

In #90315 the PageLayoutView was refactored. Mainly
`getTable_tt_content` was spitted in smaller functions.

Therefore a new function `generateLanguageView` was
introduced but missed `defLangBinding` in the parameter
signature. The parameter is now registered and correctly
passed to the function.

Resolves: #90617
Relates: #90315
Releases: master, 10.4
Change-Id: Ic7d4817cfc1799f2f95aec628fabeba7240b511c
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/66014
Tested-by: TYPO3com <>
Tested-by: Mathias Brodala <>
Tested-by: Georg Ringer <>
Reviewed-by: Mathias Brodala <>
Reviewed-by: Georg Ringer <>

Revision daf5fc36 (diff)
Added by Oliver Bartsch 18 days ago

[BUGFIX] Pass defLangBinding to generateLanguageView

In #90315 the PageLayoutView was refactored. Mainly
`getTable_tt_content` was spitted in smaller functions.

Therefore a new function `generateLanguageView` was
introduced but missed `defLangBinding` in the parameter
signature. The parameter is now registered and correctly
passed to the function.

Resolves: #90617
Relates: #90315
Releases: master, 10.4
Change-Id: Ic7d4817cfc1799f2f95aec628fabeba7240b511c
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65983
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Susanne Moog 8 months ago

  • Description updated (diff)

#2 Updated by Georg Ringer 8 months ago

  • Target version set to 10 LTS

#3 Updated by Daniel Goerz 8 months ago

#4 Updated by Daniel Goerz 8 months ago

  • Related to deleted (Feature #78450: Introduce PreviewRenderer pattern)

#5 Updated by Daniel Goerz 8 months ago

  • Related to Task #90348: PageLayoutView and BackendLayout should be refactored to separate rendering, processing and fetching of content added

#6 Updated by Susanne Moog 8 months ago

  • Subject changed from No content elements displayed with mod.web_layout.defLangBinding to Page Module: No content elements displayed with mod.web_layout.defLangBinding

#7 Updated by Susanne Moog 8 months ago

  • Assignee set to Claus Due

#8 Updated by Claus Due 8 months ago

  • Status changed from New to Needs Feedback

I'm not able to reproduce this - can you provide more information about records/columns required to reproduce?

My test setup:

  • Two columns
  • Two content elements in each
  • Three languages
  • Language A translated in "connected" mode
  • Language B translated in "free" mode
  • Content shown in "languages" mode with default language or either of the two additional languages selected
  • Content shown in "columns" mode with any language selected

No difference between "Fluid based page module" feature toggle enabled/disabled.

The "defLangBinding" toggle is set the same way as before, in PageLayoutController.

Possibly related to https://review.typo3.org/c/Packages/TYPO3.CMS/+/63513?

#9 Updated by Claus Due 8 months ago

Wrong patch link, sorry. Right link is: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63520

#10 Updated by Susanne Moog 7 months ago

  • Status changed from Needs Feedback to In Progress

Still not working and in different ways in the two page module variants. I even reinstalled the complete system yesterday and I can still reproduce it just fine.

To reproduce:
- Install introduction package (good default test cases ;))
- Add TSConfig: `mod.web_layout.defLangBinding = 1` to TSConfig of root page ("Congratulations")

Result:
- On the "old" page module in "Languages" mode (because that's where the setting takes effect): no content rendered at all
- In the "new" page module in "Languages" mode: setting has no effect at all (items should be aligned but aren't) - easiest to see in mixed mode, but also wrong in connected mode (as there should be a visual connection)

#11 Updated by Susanne Moog 7 months ago

#12 Updated by Susanne Moog 7 months ago

attached are some additional screen shots on how it looks with the setting working (enabled and disabled)

#13 Updated by Benni Mack 7 months ago

  • Parent task set to #90812

#14 Updated by Riccardo De Contardi 7 months ago

  • Related to Bug #90866: Fluid based page module not showing elements with language=All ([sys_language_uid]=-1) added

#15 Updated by Benni Mack 6 months ago

  • Target version changed from 10 LTS to next-patchlevel

#16 Updated by Helmut Hummel about 1 month ago

  • Duplicated by Bug #92360: with mod.web_layout.defLangBinding set to true, no content output is generated added

#17 Updated by Mathias Brodala 23 days ago

  • Blocks Bug #92454: Invalid colPos/language UID used in "Languages" view with defLangBinding added

#18 Updated by Gerrit Code Review 19 days ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66014

#19 Updated by Gerrit Code Review 19 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66014

#20 Updated by Oliver Bartsch 19 days ago

  • Assignee deleted (Claus Due)
  • Is Regression set to Yes

Susanne Moog wrote:

Result:
- On the "old" page module in "Languages" mode (because that's where the setting takes effect): no content rendered at all
- In the "new" page module in "Languages" mode: setting has no effect at all (items should be aligned but aren't) - easiest to see in mixed mode, but also wrong in connected mode (as there should be a visual connection)

Hi Susanne,

you are right. The fluid based page module is missing this functionality completely. But as this issue is about a regression, introduced with #90315 in the "old" page module, I've created a separate issue #92482 for the fluid based page module (about the missing functionality).

#21 Updated by Oliver Bartsch 19 days ago

  • Related to Task #90315: Split up PageLayoutView code into smaller chunks added

#22 Updated by Oliver Bartsch 19 days ago

  • Related to Bug #92482: Fluid based page module is missing defaultLanguageBinding functionality added

#23 Updated by Oliver Bartsch 18 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#24 Updated by Gerrit Code Review 18 days ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65983

#25 Updated by Oliver Bartsch 18 days ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF