Project

General

Profile

Actions

Bug #15339

open

localization fails if content is moved from other language to default language

Added by Daniel Chabrol over 18 years ago. Updated 12 months ago.

Status:
Under Review
Priority:
Should have
Category:
Localization
Target version:
-
Start date:
2005-12-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello!

I copied a page from an old site to a new one, to have some initial content. The old site uses german as default language (uid=0) and english as localization language (uid=1). The new one uses english as default language. So the copied english content shows up in the wrong language in the new system. So I moved the contests in the laguages view of the page module from right to left (into the default column).
But now the problem occurs: If you now press "copy default content elements" to localize the contents at the new site, the following error occurs:

Errors: 1: Localization failed; Source record contained a reference to an original default record (which is strange)!

If you set the content-elements l18n_parent to zero (in phpMyAdmin) it works.

You can reproduce the effect the following, shorter way:
1) Create an content element and localize it.
2) Move the localized version in the default-language column.
3) Press "copy default content elements" to localize it again.

Best regards,
Daniel

(issue imported from #M2142)


Related issues 3 (2 open1 closed)

Related to TYPO3 Core - Bug #19014: Copying Content Elements does not copy Language OverlaysClosedRupert Germann2008-06-25

Actions
Related to TYPO3 Core - Epic #101557: Translation Handling FindingsNew2023-08-03

Actions
Related to TYPO3 Core - Story #101561: DataHandler related translation issuesNew2023-08-03

Actions
Actions #1

Updated by Thorsten Kahler about 13 years ago

The value of l18n_parent should be reset when moving content elements to other languages, especially when moving to the default language.

The same applies for copies of records, especially since they're copied along with their translations, see bug #19014 and svn revision r6195.

Actions #2

Updated by Alexander Opitz about 10 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version changed from 3.8.0 to 4.4
  • PHP Version deleted (5)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.1.7)?

Actions #3

Updated by Alexander Opitz about 10 years ago

  • TYPO3 Version changed from 4.4 to 4.0
Actions #4

Updated by Alexander Opitz almost 10 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions #5

Updated by Michael B. over 9 years ago

Error still exists in TYPO3 6.2.6 :(

Actions #6

Updated by Jigal van Hemert over 8 years ago

  • Category set to Localization
  • Status changed from Closed to New
Actions #7

Updated by Lars Peter Søndergaard over 8 years ago

I asked to reopen this issue. Here the content of my mail:


To reiterate the steps from the bug report:

  1. Create a content element in default language and localize it by clicking on "Copy default content elements".
  2. Move the localized version in the default-language column (by changing the language in the content elements settings). You should now have two content elements in the default column.
  3. Try to localize both elements again by clicking on "Copy default content elements".

You get this error:
"1: [newlog()] Localization failed; Source record contained a reference to an original default record (which is strange)!"

Screenshot:
http://img.xrmb2.net/images/393570.png

Note: If I delete the original content element ("Beispieltext" in default column) all three content elements visible in the screenshot get deleted (which certainly is not what you would expect).

To make it work with current versions, I actually created a 4.5 compatible extension: https://github.com/lsoendergaard/localfix

Actions #8

Updated by Riccardo De Contardi almost 7 years ago

I performed a test with the latest master:

1) I have 2 languages, Default (ITA) and English (ENG, ID=1)
2) Create a page "Test 15339"
2.1) translate it in ENG "Test 15339 ENG"
3) in ITA > create a Text element "Test"
3.1) Page view > choose "languages" view
3.2) Translate it clicking on "translate and choose "translate"
4) Edit the translated "Test" CE > rename its headline to "Test 2"
4.1) Tab "Language" > set its language to Italian
4.2) Now I have 2 content in "Italian" column, "Test" and "Test 2"
4.3) Translate it clicking on "translate and choose "translate"

5) Result 1: Only "Test" Will be translated, but not "Test 2" (but the modal lists both the CEs)

No error is thrown

6) Delete the original CE "Test"

7) Result 2: all CE are deleted

My explanation: I think that the behavior observed is related to this: when you switch the language of the CE "Test 2" from ENG to ITA, the field "Transl.Orig:" is not cleared! if you clear it, the behavior will be the correct one.
The same (correct) behavior will be triggered if you choose "Copy" instead of "Translate" on point 3.2

Proposal:

When switching the language (point 4.1) to the default language, automatically clear the "Transl. Orig." field. OR open a modal alert box that warns you about what will happen and offers you to clear that field.

Actions #9

Updated by Wolfgang Klinger over 6 years ago

  • Assignee set to Wolfgang Klinger
  • TYPO3 Version changed from 4.0 to 9
Actions #10

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #11

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #12

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #13

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #14

Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #15

Updated by Gerrit Code Review over 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #16

Updated by Gerrit Code Review over 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53787

Actions #17

Updated by Riccardo De Contardi almost 6 years ago

still present on 9.4.0-dev

Actions #18

Updated by Susanne Moog about 5 years ago

  • Status changed from Under Review to Accepted

Review was abandoned.

Actions #19

Updated by Daniel Haupt 12 months ago

I can confirm the issue is still present on 13.0.0-dev.

Actions #20

Updated by Gerrit Code Review 12 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/78965

Actions #21

Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/78965

Actions #22

Updated by leon jänicke 9 months ago

  • Related to Epic #101557: Translation Handling Findings added
Actions #23

Updated by Jo Hasenau 9 months ago

  • Related to Story #101561: DataHandler related translation issues added
Actions

Also available in: Atom PDF