Project

General

Profile

Actions

Bug #100348

closed

Epic #99669: CKEditor5 Collection

ckeditor 5 does not allow styling of UL/OL elements

Added by Sven Carstens over 1 year ago. Updated 9 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2023-03-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

ckeditor 4 did allow for the styling of UL/OL via css classes.
Applying the following configuration in ckeditor 5 will only allow to style the individial LI elements or a complete P element.

editor:
    config:
        style:
            definitions:
                - { name: " Checkmarks UL", element: "ul", classes: ['list-unordered-checkmarks'] }
                - { name: " Checkmarks P", element: "p", classes: ['list-unordered-checkmarks'] }
                - { name: " Checkmarks LI", element: "li", classes: ['list-unordered-checkmarks'] }

Seems to be a general problem with ckeditor 5 not yet supporting this (and other) use-cases.

Related drupal issue https://www.drupal.org/project/drupal/issues/3326261


Files

ckeditor5-bundle.js.patch (1.13 KB) ckeditor5-bundle.js.patch Hendrik N, 2023-06-14 10:33

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #100908: Update ckeditor5 to 38.0Closed2023-05-23

Actions
Actions

Also available in: Atom PDF