Feature #14902

Epic #65814: Make Indexed search extbase plugin shine

Feature #19465: Configuration enhancement for indexed_search

indexed_search: Results navigation relies on JavaScript

Added by old_zas about 14 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2005-08-04
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
easy
Sprint Focus:

Description

Links to Prev Page 1 Page 2 Next use onclick.

So there is no way to navigate through results pages with disabled or missing JavaScript support.

This is a major accessibility issue.

(issue imported from #M1347)

bug-1347_01.patch View (2.6 KB) Administrator Admin, 2006-10-13 13:07

bug-1347_02.patch View (2.95 KB) Administrator Admin, 2006-10-13 15:21

20080115_indexed_search_no_javascript.patch View (3.19 KB) Administrator Admin, 2008-01-15 11:51

bug-1347_03.patch View (5.07 KB) Administrator Admin, 2008-03-19 14:38

14902_6.0_v2.patch View (4.88 KB) Ralf Hettinger, 2013-04-25 21:19


Related issues

Related to TYPO3 Core - Bug #16513: Browselist links doesn't work with config.baseURL Closed 2006-08-31
Duplicated by TYPO3 Core - Feature #10667: Pagebrowser without Javascript Closed 2010-11-07

History

#1 Updated by old_zas about 14 years ago

version 2.1.3 typo3 3.8.0

#2 Updated by Michael Stucki almost 14 years ago

I think this should be made configurable.

#3 Updated by Sacha Vorbeck almost 14 years ago

keyword:accessibility

#4 Updated by Wolfgang Klinger almost 14 years ago

I would generally change from POST to GET

#5 Updated by old_zas over 13 years ago

Still no fix for this issue ?

#6 Updated by Michael Stucki over 13 years ago

@Wolfgang: Masi once sent me some comments about shortening the arguments in order to make browsing with GET parameters possible. Currently it would probably not work because the URL becomes too long.

#7 Updated by old_zas over 13 years ago

That issue prevents Typo3 indexed search extension to be used for fully accessible websites.

#8 Updated by Daniel Ditgens almost 13 years ago

Problem solved on www.greenpeace.de

however they done it :-)

#9 Updated by Michael Stucki almost 13 years ago

Why not ask them for a small contribution?

#10 Updated by Thorsten Kahler almost 13 years ago

I'm currently working on a solution that creates URLs as value of the href attribute. But this is for an older version, so I need some time to create a patch file for the current version.

IMHO this solution isn't optimal. It would be better to create a submit button for every page so the URLs aren't screwed up. But I didn't dig into that solution yet.

#11 Updated by Thorsten Kahler almost 13 years ago

The attached diff introduces a new attribute $pointerVars in class tx_indexedsearch. This is filled with the necessary piVars when makePointerSelector_link() is called for the first time. So the list of parameters in the URL doesn't get too long.

The generation of URLs instead of "#" is disabled by default and can be enabled by setting plugin.tx_indexedsearch.browseLinks_setUrl in TS.

#12 Updated by Daniel Ditgens almost 13 years ago

Many many thanks for the patch, Thorsten! Great work. I've edited your patch (so the line number may be wrong) because I don't want those onclick events if I use "browseLinks_setUrl". I added some XHTML-compliance with htmlspecialchars on $url.

#13 Updated by Benni Mack almost 12 years ago

Hey Patrick,

any chance on sending this patch again to the core list so it goes int o 4.2 ?

#14 Updated by Benni Mack over 11 years ago

Guys, I created a new version of this patch, that applies against the current trunk. Anyone interested in putting this to the core list?

#15 Updated by Ralf Hettinger over 11 years ago

And one more patch for this old issue.

Attached bug-1347_03.patch fully contains Thorstens/Benjamins solution.

Additionally, it implements Thorsten's idea, mentioned on 2006-10-11: to render the browselinks as forms, thus preventing any shortcomings that may arise by extended length of the browselink-URLs.

Alternatively to the property (renders browslinks as URLs, not needing JS)
plugin.tx_indexedsearch.browseLinks_setUrl = 1

you may use the property (renders browselinks as forms, not needing JS)
plugin.tx_indexedsearch.browseLinks_useForms = 1

with browseLinks_setUrl having precedence to browseLinks_useForms.

If browseLinks_useForms = 1, you may want to add additional parameters to each submit button (for more styling maybe) by adding them to
browseLinks_useForms.submit_params

Example:
browseLinks_setUrl = 0
browseLinks_useForms = 1
browseLinks_useForms.submit_params = class="myclass"

#16 Updated by Ralf Hettinger over 11 years ago

Any objections against putting this to the core list for 4.2.1?

#17 Updated by Darren Clark almost 10 years ago

Confirmed that the patch works with 4.2.8 and fixes the javascript invalid pointer issue with firefox 3.5.3

#18 Updated by Ralf Hettinger almost 10 years ago

related to #19465 (patch 0009574_v7.patch)

#19 Updated by Alexander Opitz over 6 years ago

  • Target version deleted (0)
  • TYPO3 Version set to 4.4

#19465 (patch 0009574_v7.patch)

#20 Updated by Ralf Hettinger over 6 years ago

  • File 14902_6.0.patch added

Adding a patch for TYPO3 6.0, suggesting the following TS parameters:

plugin.tx_indexedsearch.pageBrowser {

  # result navigation with hyperlinks
  makePointerLinksWithHref = 0
  makePointerLinksWithHref {
    ATagParams = class="tx-indexedsearch-pointerLink" 
  }

  # result navigation with form and submit button
  makePointerLinksWithForm = 0
  makePointerLinksWithForm {
    submit_params = class="tx-indexedsearch-pointerButton" 
  }
}

#21 Updated by Ralf Hettinger over 6 years ago

Whoops... wrongly diffed. Please use 14902_6.0_v2.patch

#22 Updated by Chris topher over 6 years ago

  • File deleted (14902_6.0.patch)

#23 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20189

#24 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20189

#25 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20189

#26 Updated by Ernesto Baschny over 6 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Results navigation relies on JavaScript to indexed_search: Results navigation relies on JavaScript
  • Assignee deleted (Patrick Broens)
  • Target version set to 6.2.0
  • Complexity set to easy

#27 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20189

#28 Updated by Ernesto Baschny almost 6 years ago

  • Target version deleted (6.2.0)

A very long standing issue, and now with a comprehensive implementation suggestion by Wouter, but we'll have to postpone that for post-6.2 releases. But please don't forget about it!

#29 Updated by Thomas Scheibitz almost 5 years ago

When will this Patch get merged into the core? Is this Ticket still active?

#30 Updated by Tymoteusz Motylewski over 4 years ago

  • Parent task set to #19465

#31 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/20189

#32 Updated by Karsten Nowak (undkonsorten) over 4 years ago

Patch is working for me.
Because of wrong line numbers i had to patch manually but it works.

I use it in TYPO3 6.2.9.

#33 Updated by Jens Schmietendorf over 4 years ago

It's working fine for me, too.
My TYPO3 Version is 6.2.9

#34 Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/20189

#35 Updated by Tymoteusz Motylewski about 4 years ago

Hi
I'm wondering whether this patch makes sense any more in 2015.
The original issue was created ~10 years ago, when relaying on js for navigation was an accessibility issue.
I don't think this is a case right now.

I know that the indexed search js is not pretty, but this is a different topic.

So, I'm opting for abandoning the issue. However if you really see the usecase, please let me know, maybe I miss something.

#36 Updated by Ralf Hettinger about 4 years ago

-1 for abandoning for the following reasons:
  • avoid "crufty" inline JS
  • enable easy interception of paging action by JavaScript and doing paging with AJAX afterwards (quite dirty to achieve this with the standard JS)
  • avoid very long GET http requests with the POST option; GET might even lead to errors, if webserver doesn't accept very long GET requests

#37 Updated by Daniel Maier about 4 years ago

  • Status changed from Under Review to Closed

As suggested (see comments of Tymoteusz Motylewski) ticket is closed, because in 2015 there should be no real need anymore for Non-JS-Fallbacks.

#38 Updated by Ralf Hettinger about 4 years ago

Just for the records: I'm against closing this issue for the reasons mentioned in #note-36

Also available in: Atom PDF