Bug #25006

Backend search for page ID (uid) doesn't expand pagetree any more

Added by Peter Kraume about 9 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-02-11
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
nightmare
Is Regression:
Sprint Focus:

Description

In TYPO3 < 4.5 it was possible to enter the uid of a page into the backend search field in upper right corner. Upon hitting the enter key, the corresponding page was highlighted in the pagetree and the pagetree expanded to the fitting subpage.
Currently only the matching pageproperties open in the main frame but the pagetree remains untouched.

(issue imported from #M17549)

typo3-pagetree-filtering.png View (7.94 KB) Christian Buelter, 2011-08-19 09:59


Related issues

Related to TYPO3 Core - Bug #24688: Pagetree cannot be initialized with a specific page ID Closed 2011-01-20
Related to TYPO3 Core - Bug #33853: Selection lost after leaving filtering-mode Closed 2012-02-11
Duplicated by TYPO3 Core - Bug #29151: Update page tree after clicking on search result Closed 2011-08-22
Duplicated by TYPO3 Core - Bug #31894: Highlight current page after search Closed 2011-11-17

Associated revisions

Revision 582905ba (diff)
Added by Stefan Galinski almost 8 years ago

[BUGFIX] Pagetree should expand to the last selected node

The patch integrates the expansion to the last selected node
at least for the following functions:
- selected node of the filtering tree
- OpenDocs
- Shortcuts (if possible)
- Live Search

Fixes: #25006
Fixes: #33853
Releases: 6.0, 4.7, 4.6, 4.5

Change-Id: I1a47bedd10a37a8931ccd50c7fd119399834d909
Reviewed-on: http://review.typo3.org/10357
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert
Reviewed-by: Wouter Wolters
Tested-by: Marcus Schwemer
Reviewed-by: Stefan Galinski
Tested-by: Stefan Galinski

Revision 63fd246e (diff)
Added by Stefan Galinski almost 8 years ago

[BUGFIX] Pagetree should expand to the last selected node

The patch integrates the expansion to the last selected node
at least for the following functions:
- selected node of the filtering tree
- OpenDocs
- Shortcuts (if possible)
- Live Search

Change-Id: Ibe9ea4c826b6c59f72eab4945cf5cb4d30e306d3
Fixes: #25006
Fixes: #33853
Releases: 6.0, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/10376
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert
Reviewed-by: Tolleiv Nietsch
Tested-by: Tolleiv Nietsch

History

#1 Updated by almost 9 years ago

This is not only valid for a search by UID, but for every page result: If your search result is a page and you click the result, the page properties are opened, but the tree isn't expanded. So you still don't have any idea where the page is to be found.

#2 Updated by Webadmin no-lastname-given over 8 years ago

Is there any chance to get this working in 4.5 again? Our editors are asking for it twice a day :(

#3 Updated by Christian Buelter over 8 years ago

This has been nicely integrated into the pagetree itself. Just enter the page uid in the input field above the pagetree. See attached screenshot.

It's not exactly the same behaviour, but it works very well.

So I guess this issue can be closed.

#4 Updated by Peter Kraume over 8 years ago

I know the filter feature! But the problem is, that the pagetree collapses to the old view when you remove the filter.

In former TYPO3 versions it was possible to search for a pageid and then the page tree expanded automatically to the corresponding page and kept this view until manual change.

#5 Updated by Lorenz Ulrich over 8 years ago

I agree with Peter that this cannot be closed. This behaviour was a feature that was forgotten with the new search and pagetree. I have an installation I cannot update from 4.4 because the integrators say they really need this feature...

#6 Updated by Bas v.d. Wiel over 8 years ago

Totally agree with Peter here. From a usability standpoint it's ridiculous to have a search result open, but only part of your input interface updated. Our website is tens of thousands of pages in size. Search will dig up some obscure page and open it in the right pane, without the editor having any clue where in the page tree this page is actually to be found. Search interfaces are supposed to find stuff, not leave users in the dark. Christian's suggestion is a workaround but not a solution as far as I'm concerned.

#7 Updated by Stefan Galinski about 8 years ago

  • Assignee deleted (Stefan Galinski)

#8 Updated by Martin Bless almost 8 years ago

Peter Kraume wrote:

In TYPO3 < 4.5 it was possible to enter the uid of a page into the backend search field in upper right corner. Upon hitting the enter key, the corresponding page was highlighted in the pagetree and the pagetree expanded to the fitting subpage.

Peter is right. IMHO it's an urgent MUST HAVE to get that feature back. The lack of it drives me crazy right now at sites with thousands of pages.

If at least the selected page in the pagetree would keep being selected when I remove the filter.

#9 Updated by Ernesto Baschny almost 8 years ago

  • Target version deleted (0)

@Martin: The mentioned "selected page would keep being selected when I remove the filter" is another issue (also worth fixing): #33853.

#10 Updated by Stefan Galinski almost 8 years ago

  • Assignee set to Stefan Galinski

#11 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/10357

#12 Updated by Stefan Galinski almost 8 years ago

  • Complexity set to nightmare

#13 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/10376

#14 Updated by Stefan Galinski almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/11048

#16 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/11048

#17 Updated by Mohamed Rafeek over 7 years ago

I am using the same patch which is mentioned here but i am not able see the highlight the page after the search in page-tree. I am using typo3 4.5.11

Any one please help me on this.

#18 Updated by Stefan Galinski over 7 years ago

Which patch did you applied? This one: https://review.typo3.org/#/c/11048/?

#19 Updated by Mohamed Rafeek over 7 years ago

Yes, I have updated this patch https://review.typo3.org/#/c/11048/ in my core file (Typo3 4.5.11).

I am able to see the page tree get expanded on the selected search page (while editing the searched page) but the selected page is not get highlighted in the page tree.

#20 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/13132

#21 Updated by Stefan Galinski over 7 years ago

  • Status changed from Under Review to Resolved

#22 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF