Bug #41411

RTE: Cursor jumps to first letter with Chrome 22

Added by Webadmin no-lastname-given over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2012-09-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With the new Chrome Version 22 it is impossible to write anything in the RTE. When you enter some chars, the cursor will jump to the first letter in the current line.


Related issues

Has duplicate TYPO3 Core - Bug #41417: htmlarea rte with chrome 22.xClosed2012-09-27

Actions
Precedes TYPO3 Core - Bug #41796: RTE: Uncaught error in Firefox in TYPO3 6.0ClosedStanislas Rolland2012-10-09

Actions
#1

Updated by Michael Grundkötter over 8 years ago

I can confirm this in 4.7.4. as well. This is very annoying! Editing anything becomes literally impossible.

#2

Updated by Stefan Galinski over 8 years ago

  • Status changed from New to Accepted
#3

Updated by Adis Durakovic over 8 years ago

I can also confirm with 4.7.2... Chrome 22 on OSx 10.8.2
btw. i reported this bug on bugs.typo3.org... but it's status is still set to "new" ... are there any bug-operations there?

#4

Updated by Webadmin no-lastname-given over 8 years ago

It seems to be more an issue within Chrome. I checked the current nightly build (Version 24) and it works fine again. Would be good, if someone can check this also on OSx

https://tools.google.com/dlpage/chromesxs

The current beta version seems to have the issue too.

#5

Updated by Bastian Bringenberg over 8 years ago

Yep, I can confirm, that the nightly build you posted fixes this problem under Mac OsX =).

#6

Updated by Christian Brinkert over 8 years ago

I can confirm that the problem seems to be solved with the nightly build of chrome (version 24.x) in TYPO3 version 4.5 and even in version 4.7 (under Windows7).

#7

Updated by Christian Nölle over 8 years ago

Can confirm this as well under W7 x64 with T3 LTS latest and 4.7 latest. Upgrade to Chrome 24.x canary solved the problem.

#8

Updated by t3agent Christian Händel over 8 years ago

The official Chrome version have this bug, tested with T3 4.5.17 - 4.5-19, 4.6.6, 4.7.2 - 4.7.4
Must be fixed immediatly. Any one outside there to fix this?

#9

Updated by Stanislas Rolland over 8 years ago

  • Assignee set to Stanislas Rolland
  • Target version set to 4.5.20
#10

Updated by Stanislas Rolland over 8 years ago

For some reason that needs to be further investigated, the current selection is broken in Chrome 22 when undo/redo snapshots are taken. Removing undo/redo buttons from the toolbar works around the issue.

#11

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15331

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/15334

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/15335

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15374

#15

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15374

#16

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#17

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Resolved to Under Review

Please test this change with TYPO3 4.5: http://review.typo3.org/15335

#18

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Under Review to Resolved
#19

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Resolved to Under Review
#20

Updated by Sebastian Müller over 8 years ago

I updated Chrome to Version "22.0.1229.92 m" right now. The bug is gone ;)

#21

Updated by Thomas Trethan over 8 years ago

I can confirm that the Patch is working for Typo3 4.5.19.

#22

Updated by Edward Lenssen over 8 years ago

Same for me.
I updated Chrome to Version "22.0.1229.92 m" right now. The bug is gone ;) Looks no patch is needed.
4.5.19 and 4.7.4

#23

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Under Review to Resolved
#24

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF