Feature #86620

Update "slug" for all sub pages in TYPO3 9

Added by Martin Weymayer about 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-04-08
Due date:
% Done:

0%

Estimated time:
PHP Version:
7.2
Tags:
Complexity:
Sprint Focus:

Description

It would be realy nice to have a button "Update all slugs for pages". Background:
- new typo3 9 vesion has new site configuration for "nice" url
- slug can only be updated by opening each singe page and click "update"
- so if you have website with 3 or 4 levels and you change page title in level 1, you have to update each singel page on levels 2, 3 and 4
- if you have multilanguage website and first translate pages on level 2, 3 or 4 and at the end you translate level 1 you also have to update each single page in other levels
martin

#1

Updated by Georg Ringer about 3 years ago

  • Category set to Link Handling, Site Handling & Routing
  • Status changed from New to Needs Feedback

there is already an upgrade wizard in the Install Tool: Upgrade > Upgrade Wizards > Introduce URL parts ("slugs") to all existing pages

have you found it?

#2

Updated by Martin Weymayer about 3 years ago

I am not shure if this wizard function is working as expected. first click on "upgrade wizard" showed "Introduze URL parts ..." - then I clicked "mark undone". After that wizard ran again and progress status was 100%. But trying to run this wizard again seems not working. "Introduze URL parts ..." is not showing again!?

#3

Updated by Felix Holler about 3 years ago

  • PHP Version set to 7.2

I've the same issue. Lot's of page levels and no way for fast updating the slugs of the sub pages. The upgrade wizard has no effect on the slugs after running it again as mentioned above.

#4

Updated by Simon Köhler about 3 years ago

I can confirm that the wizard is not running again.

#5

Updated by taywa gmbh almost 3 years ago

Workaround is delete set slug via SQL:

UPDATE `pages` SET `slug` = NULL where 1.

Than rerun the Wizards. See second answer on this: https://stackoverflow.com/questions/53007858/typo3-9-5-lts-automatic-regeneration-of-url-segments/53008590

#6

Updated by Alexander Dräger almost 3 years ago

There should be a feature to renew the slugs recursive within a button in the info-module like real-Url does.
AND: a possibility to set a fix slug (checkbox) which will allow the user to set custom slugs which will not be overwritten.

#7

Updated by Nils Hodyas almost 3 years ago

I would second this request. It's great to have nice urls in the core, with that feature it would be even greater.

#8

Updated by Mario Kober over 2 years ago

There is also a need for this feature because in many of my projects, editors rename pages by double clicking them in page tree. After a few month many pages have titles that do not match the slug previously entered.

Now I have to ask them to open every page, click the reload-slug-btn and save the page. It would be great to click an "update all slugs" button instead.

#9

Updated by Thomas Oliver Moll about 2 years ago

Just an info for others that stumble upon this issue: there is an extension named "sluggi" that is supposed to add this and other vital functions to TYPO3. I have not tested it yet

#11

Updated by Georg Ringer over 1 year ago

  • Status changed from Needs Feedback to Resolved

I am closing this issue because there is a solution with the extension sluggi

#12

Updated by Emile Blume over 1 year ago

  • Subject changed from Update "slug" for all pages for TYPO3 9 to Update "slug" for all sub pages in TYPO3 9
  • Status changed from Resolved to New
  • Target version set to next-patchlevel
  • Start date changed from 2018-10-10 to 2020-04-08
  • Complexity set to no-brainer

Tried the Sluggi extension (1.9.1) and used all the required settings but I doesn't change the slug for subpages. (TYPO3 9.5.15 / PHP 7.2)
This really should be part of the TYPO3 core.

#13

Updated by Andreas Fernandez over 1 year ago

  • Status changed from New to Closed
  • Target version deleted (next-patchlevel)
  • Complexity deleted (no-brainer)

Hey Emile,

this feature is part of the upcoming TYPO3 10 LTS. A backport to v9 is not feasible as this would require to backport multiple other features as well and we usually don't backport features into already released versions.

Kind regards
Andreas

#14

Updated by Daniel Flaum over 1 year ago

Would it possible to leave a brief description or reference here of how to accomplish this in v10? I arrived here from Google trying to find this functionality, and it would've been convenient if the answer were here.

#15

Updated by Marco H about 1 year ago

Andreas Fernandez wrote:

this feature is part of the upcoming TYPO3 10 LTS.

As Daniel asked - is it now?

#16

Updated by Michael Bakonyi about 1 year ago

To more easily update several subpages slugs at once use the List-module: add the slug-field as column, click the edit-field of the column and update the slugs manually by clicking the refresh buttons. This is at least a quicker solution than editing every page one by one.

#17

Updated by Torben Hansen 11 months ago

Marco H wrote in #note-15:

Andreas Fernandez wrote:

this feature is part of the upcoming TYPO3 10 LTS.

As Daniel asked - is it now?

Yes it is - see #89115

However, it seems the automatic update process still needs some enhancements/streamlining - see #89301

Also available in: Atom PDF