Project

General

Profile

Actions

Story #46140

closed

Add configurable linkhandler for arbitrary records

Added by Jigal van Hemert over 11 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2015-04-10
Due date:
2015-04-11
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
7
PHP Version:
Tags:
Sprint Focus:
Remote Sprint

Description

Integrate the well-known features of the aoe_linkhandler extension into the core.

The functionality shall not be integrated as another sysext, but should be a basic functionality.

For 6.x+ there are various attempts for compatible version, but all of them have different feature sets, the most notable are:

The functionality actually comprises multiple features, which will be handled in subtasks.


Subtasks 13 (0 open13 closed)

Task #66369: Introduce an API for adding tabs to the ElementBrowserClosedMarkus Klein2015-04-10

Actions
Task #66370: Add generic preview URL generator APIClosedMarkus Klein2015-04-10

Actions
Task #66372: Add a tab handler which can handle the selection of arbitrary recordsClosedMarkus Klein2015-04-112015-04-11

Actions
Task #66373: Extend typolink to handle record linksClosedMarkus Klein2015-04-10

Actions
Task #66374: Ensure the softref parser properly handles record linksClosedMarkus Klein2015-04-10

Actions
Task #66375: Adjust the linkvalidator task to handle the record linksClosedMarkus Klein2015-04-10

Actions
Task #68394: Cleanup ElementBrowser related classesClosedMarkus Klein2015-07-20

Actions
Task #69136: Remove unused and redundant code in ElementBrowserClosedMarkus Klein2015-08-17

Actions
Task #69276: Remove global usage of SOBE in Tree contextClosedMarkus Klein2015-08-24

Actions
Task #69315: Streamline ElementBrowser mode handlingClosedMarkus Klein2015-08-25

Actions
Bug #70294: additionalGetParameters in PageTS TCEMAIN.preview function does not work with parameter arrayClosedMarkus Klein2015-10-02

Actions
Bug #71494: image wizard in the rtehtmlareaClosedMarkus Klein2015-11-12

Actions
Task #71840: Style linkhandlers with BootstrapClosed2015-11-25

Actions

Related issues 11 (2 open9 closed)

Related to TYPO3 Core - Feature #66218: Linkhandler for ShortcutNew2015-04-01

Actions
Related to TYPO3 Core - Bug #67199: Wrong parameter passer to linkhandler hookClosedFrancois Suter2015-05-29

Actions
Related to TYPO3 Core - Feature #62024: Add a querystring picker to browse_links.phpClosed2014-10-03

Actions
Related to TYPO3 Core - Bug #71298: Fix missing/broken RTE features after Link Handler API mergeAcceptedMarkus Klein2015-11-02

Actions
Related to TYPO3 Core - Bug #71230: Active node of tree is not highlightedClosedJosef Glatz2015-11-01

Actions
Related to TYPO3 Core - Bug #71302: ElementBrowser (e.g. group field) using find button, ordering links or extend table button results in Backend reload insteadClosed2015-11-04

Actions
Related to TYPO3 Core - Feature #79626: Integrate linkhandler into coreClosed2017-02-04

Actions
Related to TYPO3 Core - Feature #81623: Create a Hook for LinkhandlingClosed2017-06-20

Actions
Is duplicate of TYPO3 Core - Feature #42831: Link to recordsClosed2012-11-10

Actions
Has duplicate TYPO3 Core - Feature #48171: Including RTE linkhandler into coreClosed2013-05-14

Actions
Has duplicate TYPO3 Core - Feature #65701: Add linkhandler to the CoreClosed2015-03-12

Actions
Actions #1

Updated by Stefano Cecere over 11 years ago

just as reminder: F. Suter has just updated linkhandler to work with 6.0

https://github.com/fsuter/linkhandler

should be this the starting point?

Actions #2

Updated by Jigal van Hemert over 11 years ago

  • Target version changed from 6.1.0 to 6.2.0
Actions #3

Updated by Ernesto Baschny almost 11 years ago

  • TYPO3 Version changed from 6.1 to 6.2

Great idea. Is this still doable for 6.2?

Actions #4

Updated by Ernesto Baschny almost 11 years ago

  • Category changed from Miscellaneous to Backend API
Actions #5

Updated by Ernesto Baschny over 10 years ago

  • Target version deleted (6.2.0)

Would have been a nice 6.2 feature, but we postpone it for a future release then.

Actions #6

Updated by Joh. Feustel over 10 years ago

A 6.2 compatible version based on F. Suters fork is available at https://github.com/AOEmedia/linkhandler to be prepared for becoming a sysext.

Actions #7

Updated by Dennis Füllgraf over 10 years ago

This Version (https://github.com/AOEmedia/linkhandler) is not compatible with 6.2.beta7. Error on Tab News: "#1392409507: Invalid form/module token detected. Access Denied"

Actions #8

Updated by Jigal van Hemert over 10 years ago

@Dennis: Please report the problem to the owner of the extension. Integration was not finished enough before feature freeze and will probably be combined with the refactoring of the linkwizard in a future release.

Actions #9

Updated by Mathias Schreiber over 9 years ago

  • Status changed from Accepted to Closed

will continue in #46140:

Actions #10

Updated by Mathias Schreiber over 9 years ago

  • Status changed from Closed to Accepted
Actions #11

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #12

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #13

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #14

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #15

Updated by Jigal van Hemert over 9 years ago

  • Assignee changed from Jigal van Hemert to Markus Klein
Actions #16

Updated by Gerrit Code Review over 9 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #17

Updated by Björn Jacob over 9 years ago

I just wanted to mention that the guys from Intera released a great extended version of the linkhandler. Please see and check https://github.com/Intera/typo3-extension-linkhandler. I think some of the additional features are quit interesting.

Actions #18

Updated by Markus Klein over 9 years ago

Oh, thanks for info... means I've to redo the whole patch, though.
Hope I'll be able to do that within the next week, the old patch took me 10 hours alone.

Actions #19

Updated by Gerrit Code Review over 9 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #20

Updated by Gerrit Code Review over 9 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #21

Updated by Gerrit Code Review over 9 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37816

Actions #22

Updated by Markus Klein over 9 years ago

  • Tracker changed from Feature to Story
  • Subject changed from Configurable linkhandler for records to Add configurable linkhandler for arbitrary records
  • Description updated (diff)
  • Target version set to 7.2 (Frontend)
  • Translation missing: en.field_remaining_hours set to 0.0
  • TYPO3 Version set to 7
Actions #23

Updated by Markus Klein over 9 years ago

  • Description updated (diff)
  • Sprint Focus set to Remote Sprint
Actions #24

Updated by Markus Klein over 9 years ago

I abandoned the patch and decomposed the requirements into separate tasks to ease the reviews.

Actions #25

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
Actions #26

Updated by Markus Klein about 9 years ago

  • Category changed from Backend API to Link Handling, Site Handling & Routing
Actions #27

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #28

Updated by Francois Suter almost 9 years ago

How much hope is there of this feature making it into 7 LTS? I'm getting totally desperate about getting extension "linkhandler" to work with 7.x. With every new release something else breaks.

Actions #29

Updated by Markus Klein almost 9 years ago

Hi Francois!

I'm extremely busy implementing this feature! I'm working at least 10h per week on this topic only. As you can see with the subtasks I split this "mess" into several subtasks. Currently I'm tearing apart the code of ElementBrowser in focused classes. This way I got a good picture what is going on there and I'm 70% through. Once the "Tabbing API" for the ElementBrowser is done, the remainder is relatively easy.

So, yes, 7.5 still is the target.

Actions #30

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #31

Updated by Andreas Allacher almost 9 years ago

7 LTS still the target or might this feature be moved to 8.x ?

Actions #32

Updated by Markus Klein almost 9 years ago

Still the target!

Actions #33

Updated by Markus Klein over 8 years ago

  • Tracker changed from Story to Bug
  • Status changed from Under Review to New
  • Is Regression set to No
Actions #34

Updated by Markus Klein over 8 years ago

  • Tracker changed from Bug to Story
Actions #35

Updated by Markus Klein over 8 years ago

  • Target version changed from 7 LTS to 8 LTS

I would like to inform you all on the current state of this story.

I worked heavily to prepare the Core to provide a cleaner API to make the link browser extensible, and it was an aweful load of work to reach this, but hey, we made it!
Unfortunately, due to some private matters, I didn't manage to incorporate all funtionality of the linkhandler extension into the Core until the 7 LTS release.
Fortunately, Francois started to work on the patch for this in parallel and a promising draft is ready. As there is no chance anymore to merge this into 7, Francois will publish this patch in a new version of the linkhandler extension. Luckily, it is now much easier to integrate this functionality with the extension (without a lot of x-classing and so on).

Once we have this extension stable, we will finally merge the functionality to version 8 of the Core.

Thanks for your patience and sorry for not making it 100% perfect for CMS 7.

Cheers, Markus

Actions #36

Updated by Bas van der Togt over 8 years ago

Great work guys!
Is the extension already available?

Actions #37

Updated by Markus Klein over 7 years ago

  • Status changed from New to Resolved
Actions #38

Updated by José Ricardo about 7 years ago

Actions #39

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF